summaryrefslogtreecommitdiff
path: root/games-fps/postal2
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/postal2')
-rw-r--r--games-fps/postal2/Manifest4
-rw-r--r--games-fps/postal2/metadata.xml8
-rw-r--r--games-fps/postal2/postal2-1409.2-r2.ebuild68
3 files changed, 80 insertions, 0 deletions
diff --git a/games-fps/postal2/Manifest b/games-fps/postal2/Manifest
new file mode 100644
index 000000000000..d73f9c22f532
--- /dev/null
+++ b/games-fps/postal2/Manifest
@@ -0,0 +1,4 @@
+DIST postal2-1409.1.run 4816304 BLAKE2B a93e7af6f5332572c8344f3431ae540dd8e1b5e820244d710e578d69577dfcc533cdade56fc021d5254db30998a3b734bb527ca4e4d2f238c6ee33540b212f22 SHA512 5ff4880435394c552e7c1f33baf8dfdb71eb56fe5e3067eeb746826a25e585d3901292618668de50dc8bf641b2628a26a82cdf5b642e33f4113b55d72df9c4fe
+DIST postal2-1409.2.run 5645624 BLAKE2B 3aa4b466995344e767223d7c3296b498ca74f6b960fc32b4da7632b939df81e9d7a58836d3b9d26f5f85e51f3ba6e4a27e5b447c8318d90deede21498177ff95 SHA512 9fafcfec30d99e30b879318a96f484d3723853a213606f58b02a37631b4393ab4925022fcef3f84c95907269c6675090100358c16cec8b779140bf83fe7cb660
+EBUILD postal2-1409.2-r2.ebuild 1666 BLAKE2B ae877d64f61a0051dd375c3a235d39d2341b22459265c2c39a2c084725ffcae4a601eac3a87967b0b36d9aa891c5b4176cb1c6fb7190dcba08631eab348ab4e4 SHA512 b73dbcc452265a2143fa42b768229e88e2e23ea36b2071241d64ec56362571d0c78cb95ec7e8e00f230305a3448c87a4ea4aee718e9a24d8b8c4ddff61a3d03d
+MISC metadata.xml 252 BLAKE2B 1b951d2e730631865ae5f379b19ed9de2c8adf2f2786da3f75d0871d967374198ddd9106433f388bdc7050c37063fb28cda4320ae7bdc9a03854838693d9f952 SHA512 90798aff93ec7e3881b882e7b10bb1680e8cb7d82b0ef4280e562ab0c9e8a2daba8afe57333dc64697322267a4b651c00ee9b4fdeb56278ff70c073da7b91638
diff --git a/games-fps/postal2/metadata.xml b/games-fps/postal2/metadata.xml
new file mode 100644
index 000000000000..3c186688e265
--- /dev/null
+++ b/games-fps/postal2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-fps/postal2/postal2-1409.2-r2.ebuild b/games-fps/postal2/postal2-1409.2-r2.ebuild
new file mode 100644
index 000000000000..f0ee7ff50e1c
--- /dev/null
+++ b/games-fps/postal2/postal2-1409.2-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker cdrom multilib games
+
+DESCRIPTION="Postal 2: Share the Pain"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=postal2"
+SRC_URI="http://updatefiles.linuxgamepublishing.com/${PN}/${P/%?/1}.run
+ http://updatefiles.linuxgamepublishing.com/${PN}/${P}.run"
+
+LICENSE="postal2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="sys-libs/glibc
+ sys-libs/libstdc++-v3:5
+ amd64? ( sys-libs/glibc[multilib] sys-libs/libstdc++-v3:5[multilib] )
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[X,opengl,abi_x86_32(-)]
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cdrom_get_cds .installation_data/linux-specific.tar.bz2
+ mkdir ${A}
+
+ local f
+ for f in * ; do
+ cd "${S}"/${f}
+ unpack_makeself ${f}
+ done
+}
+
+src_install() {
+ has_multilib_profile && ABI=x86
+
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ dodir "${dir}"
+ cd "${D}/${dir}"
+
+ ln -s "${CDROM_ROOT}"/.installation_data/*.bz2 .
+ unpack ./*.bz2
+ rm -f ./*.bz2
+
+ local d
+ for d in "${S}"/* ; do
+ pushd "${d}" > /dev/null
+ loki_patch patch.dat "${D}/${dir}" || die "loki_patch ${d} failed"
+ popd > /dev/null
+ done
+
+ rm -f System/{libstdc++.so.5,libgcc_s.so.1}
+
+ dosym /usr/$(get_libdir)/libopenal.so "${dir}"/System/openal.so
+ dosym /usr/$(get_libdir)/libSDL-1.2.so.0 "${dir}"/System/libSDL-1.2.so.0
+
+ games_make_wrapper ${PN} ./${PN}-bin "${dir}"/System .
+ doicon "${CDROM_ROOT}"/.installation_data/${PN}.xpm
+ make_desktop_entry ${PN} "Postal 2: Share the Pain"
+
+ prepgamesdirs
+}