summaryrefslogtreecommitdiff
path: root/games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch')
-rw-r--r--games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch b/games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch
new file mode 100644
index 000000000000..1fe0b99d9a8e
--- /dev/null
+++ b/games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch
@@ -0,0 +1,34 @@
+From 2d1c7ba17cac3ccd201e77ad01a9dd06ab22cb2e Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Thu, 13 Jun 2019 18:01:08 +0900
+Subject: [PATCH] Install soundfonts and WOPL/WOPN banks
+
+The INSTALL_SOUNDFONT_PATH cache entry is used to configure the
+installation directory.
+---
+ src/CMakeLists.txt | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 0bb16f39e..4ff15062d 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1451,6 +1451,15 @@ add_custom_command(TARGET zdoom POST_BUILD
+ ${CMAKE_SOURCE_DIR}/fm_banks/gs-by-papiezak-and-sneakernets.wopn $<TARGET_FILE_DIR:zdoom>/fm_banks/gs-by-papiezak-and-sneakernets.wopn
+ )
+
++if( WIN32 )
++ set( INSTALL_SOUNDFONT_PATH . CACHE STRING "Directory where soundfonts and WOPL/WOPN banks will be placed during install." )
++else()
++ set( INSTALL_SOUNDFONT_PATH share/games/doom CACHE STRING "Directory where soundfonts and WOPL/WOPN banks will be placed during install." )
++endif()
++install(FILES "${PROJECT_BINARY_DIR}/soundfonts" "${PROJECT_BINARY_DIR}/fm_banks"
++ DESTINATION ${INSTALL_SOUNDFONT_PATH}
++ COMPONENT "Soundfont resources")
++
+ if( CMAKE_COMPILER_IS_GNUCXX )
+ # GCC misoptimizes this file
+ set_source_files_properties( oplsynth/fmopl.cpp PROPERTIES COMPILE_FLAGS "-fno-tree-dominator-opts -fno-tree-fre" )
+--
+2.21.0
+