summaryrefslogtreecommitdiff
path: root/games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch')
-rw-r--r--games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch b/games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch
new file mode 100644
index 000000000000..c74d08a24a47
--- /dev/null
+++ b/games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch
@@ -0,0 +1,36 @@
+From 1e09b211a000c649aae6eea736647daa650141bc Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Sat, 31 Aug 2019 21:23:23 +0900
+Subject: [PATCH] Introduce the BUILD_NONFREE option
+
+This allow users to disable building nonfree components (brightmaps.pk3
+and game_support.pk3) if they so desire.
+---
+ CMakeLists.txt | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7860358ef..23d317f42 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -404,10 +404,15 @@ add_subdirectory( libraries/lzma )
+ add_subdirectory( tools )
+ add_subdirectory( libraries/dumb )
+ add_subdirectory( libraries/gdtoa )
++
+ add_subdirectory( wadsrc )
+-add_subdirectory( wadsrc_bm )
+ add_subdirectory( wadsrc_lights )
+-add_subdirectory( wadsrc_extra )
++option (BUILD_NONFREE "Build nonfree components" ON)
++if( BUILD_NONFREE )
++ add_subdirectory( wadsrc_bm )
++ add_subdirectory( wadsrc_extra )
++endif()
++
+ add_subdirectory( src )
+
+ if( NOT CMAKE_CROSSCOMPILING )
+--
+2.23.0
+