summaryrefslogtreecommitdiff
path: root/games-engines/love/love-11.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/love/love-11.4.ebuild')
-rw-r--r--games-engines/love/love-11.4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games-engines/love/love-11.4.ebuild b/games-engines/love/love-11.4.ebuild
index fcc2e07df8e9..5cb3aaec9bc9 100644
--- a/games-engines/love/love-11.4.ebuild
+++ b/games-engines/love/love-11.4.ebuild
@@ -5,7 +5,7 @@ EAPI=8
LUA_COMPAT=( lua5-{1..4} luajit )
-inherit lua-single xdg-utils
+inherit flag-o-matic lua-single xdg-utils
if [[ ${PV} == 9999* ]]; then
inherit git-r3
@@ -47,6 +47,9 @@ src_prepare() {
}
src_configure() {
+ # Bug #858719
+ append-flags -fno-strict-aliasing
+
local myeconfargs=(
$(use_enable gme)
--with-lua=$(usex lua_single_target_luajit luajit lua)