summaryrefslogtreecommitdiff
path: root/games-engines/dMagnetic/dMagnetic-0.32.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/dMagnetic/dMagnetic-0.32.ebuild')
-rw-r--r--games-engines/dMagnetic/dMagnetic-0.32.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-engines/dMagnetic/dMagnetic-0.32.ebuild b/games-engines/dMagnetic/dMagnetic-0.32.ebuild
new file mode 100644
index 000000000000..763d4b9855db
--- /dev/null
+++ b/games-engines/dMagnetic/dMagnetic-0.32.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit prefix toolchain-funcs
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="A Magnetic Scrolls Interpreter for playing a collection of old text adventures"
+HOMEPAGE="https://www.dettus.net/dMagnetic/"
+SRC_URI="https://www.dettus.net/${PN}/${MY_P}.tar.bz2"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~m68k ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ hprefixify src/toplevel/${PN}{,_helpscreens}.c
+}
+
+src_compile() {
+ emake all \
+ CC="$(tc-getCC)" \
+ LINK="$(tc-getCC) ${LDFLAGS}"
+}
+
+src_test() {
+ emake check \
+ SHA256_CMD=sha256sum
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.6 ${PN}ini.5
+ dodoc README.txt
+
+ insinto /etc
+ doins ${PN}.ini
+}