summaryrefslogtreecommitdiff
path: root/games-engines/box2d/box2d-2.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/box2d/box2d-2.4.1.ebuild')
-rw-r--r--games-engines/box2d/box2d-2.4.1.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/games-engines/box2d/box2d-2.4.1.ebuild b/games-engines/box2d/box2d-2.4.1.ebuild
index 0fe84b500b23..aa15726dd78e 100644
--- a/games-engines/box2d/box2d-2.4.1.ebuild
+++ b/games-engines/box2d/box2d-2.4.1.ebuild
@@ -15,8 +15,17 @@ KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
IUSE="doc test"
RESTRICT="!test? ( test )"
+DEPEND="test? ( dev-cpp/doctest )"
BDEPEND="doc? ( app-doc/doxygen )"
+src_prepare() {
+ cmake_src_prepare
+
+ # unbundle doctest
+ rm unit-test/doctest.h || die
+ ln -s "${ESYSROOT}"/usr/include/doctest/doctest.h unit-test/ || die
+}
+
src_configure() {
local mycmakeargs=(
-DBOX2D_BUILD_TESTBED=OFF # bundled libs, broken anyway right now