summaryrefslogtreecommitdiff
path: root/games-emulation
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/Manifest.gzbin12072 -> 12070 bytes
-rw-r--r--games-emulation/ppsspp/Manifest1
-rw-r--r--games-emulation/ppsspp/ppsspp-1.18.1-r1.ebuild97
3 files changed, 98 insertions, 0 deletions
diff --git a/games-emulation/Manifest.gz b/games-emulation/Manifest.gz
index 3056cf2dba00..17da9e7d3ff7 100644
--- a/games-emulation/Manifest.gz
+++ b/games-emulation/Manifest.gz
Binary files differ
diff --git a/games-emulation/ppsspp/Manifest b/games-emulation/ppsspp/Manifest
index acc53b20b507..0880dea7af52 100644
--- a/games-emulation/ppsspp/Manifest
+++ b/games-emulation/ppsspp/Manifest
@@ -4,5 +4,6 @@ AUX ppsspp-1.17.1-ccache-18826.patch 1110 BLAKE2B 243a9bf36da743a4e147355703976a
AUX ppsspp-1.17.1-cmake-cxx.patch 252 BLAKE2B 4d20d67c111e9992a2a728c5d294034a3385181079d00e886aa24bb60f9bf861485d11c2292dcaee2a03c4c434cf0713664a44865bc081968369c48733b0df68 SHA512 3c122bf12349b51fbda0a86ffa3f46afad6e5a766e0ff4ea4ceda2acda90a7a758e78732fb7dc20fc8a297f3eb71e0c5d2e2de69d566268a0bbfee16490c0c79
AUX ppsspp-CMakeLists-flags.patch 913 BLAKE2B 7bd5df94b51dad35325586f7ad23284436ba670a8c2218a4a6bfb28fb5a055240aeb0543fe331310a0d86d3661cbdf418689a592139ff832802ba1fabbd10fc3 SHA512 5b2ee899b2fbed7229d4abc027e2a010327be4d334e343f977319c475feaf2d180bd74d3640022d0175b11e8256035c828dd4cf03c8a5b9240c989b2d7f72fb7
DIST ppsspp-1.18.1.tar.xz 54239412 BLAKE2B c0a59b63be4fdf8db1bb4c30192adc37874f1976baa0876a21722d8b86dac5a245cd5dbcea2f9ca89fef2035338c1786bbcf9b3c379d48d5a633ddd263b6e8d3 SHA512 00531109d67a35fe252b1af7d41a41ec85950f5d7c818bcdfb713d74b2b94f81f5af12e3e68d49ab0f7c7d29ccc42ca3ae7956f438964a205004293bb7e07510
+EBUILD ppsspp-1.18.1-r1.ebuild 2087 BLAKE2B 220b254bafa01ea74e317d9b75e7b65adce97a86d47e826172187c6d509c96929daa6c5093bd4936010c159b4aaaa0b43ea15bc626f285938ad9a90350f1ff3b SHA512 87bf04c631c09208efe5e9f6ce0d5d6cc6944df3712e3206c92c202ac9b15ee761bb658825896b39decaf0e91010ebe0236a6ddf84f08704ab77acd538e4a6f1
EBUILD ppsspp-1.18.1.ebuild 1821 BLAKE2B b6e1daced3534cdf2809b0e9605a81ba09b85069d7941073477325c803429a7149dd1204ad94052c8d1624b4f873cb6d51ec22a3d023c7848a31323b7873cb49 SHA512 7e66051fff1cd8179bd29a4b442823689de525218c1ef66fe02ccd1bf790be53bd8ccbc76e684bf6388ad5599502dec544b8e3ca37c6235c617ed4055322bf76
MISC metadata.xml 526 BLAKE2B 19d0378d36d2b1d81ce404a95d98488b54f4368c72a7397b6d7c9a444edec9c19d146295cfc247a75aca1e1b5d1643161a627b80ea76aa8d43189a5eb14380c2 SHA512 7a8c8a7c05acdc110422d7c38552c8106d1886a672e6bda1212ce9cba737ae5e89e6624010d5bc3149b8da7c061b10295a721c74e7377587ec52ec7be2237855
diff --git a/games-emulation/ppsspp/ppsspp-1.18.1-r1.ebuild b/games-emulation/ppsspp/ppsspp-1.18.1-r1.ebuild
new file mode 100644
index 000000000000..79a7ae0733b7
--- /dev/null
+++ b/games-emulation/ppsspp/ppsspp-1.18.1-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit ffmpeg-compat flag-o-matic python-any-r1 xdg cmake
+
+DESCRIPTION="A PSP emulator written in C++"
+HOMEPAGE="https://www.ppsspp.org/
+ https://github.com/hrydgard/ppsspp/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/hrydgard/${PN}.git"
+else
+ SRC_URI="https://github.com/hrydgard/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2 JSON MIT"
+SLOT="0"
+IUSE="discord qt5 test wayland"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-arch/snappy:=
+ app-arch/zstd:=
+ dev-libs/libzip:=
+ media-libs/glew:=
+ media-libs/libpng:=
+ media-libs/libsdl2[joystick]
+ media-video/ffmpeg-compat:6=
+ sys-libs/zlib:=
+ virtual/opengl
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtmultimedia:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ !qt5? (
+ media-libs/libsdl2[X,opengl,sound,video,wayland?]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.17.1-SpvBuilder-cstdint.patch"
+ "${FILESDIR}/${PN}-1.17.1-cmake-cxx.patch"
+ "${FILESDIR}/${PN}-CMakeLists-flags.patch"
+)
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # bug https://bugs.gentoo.org/926079
+ filter-lto
+
+ local -a mycmakeargs=(
+ -DBUILD_SHARED_LIBS="OFF"
+ -DCMAKE_SKIP_RPATH="ON"
+ -DHEADLESS="OFF"
+ -DUSE_CCACHE="OFF"
+ -DUSE_SYSTEM_FFMPEG="ON"
+ -DUSE_SYSTEM_LIBZIP="ON"
+ -DUSE_SYSTEM_SNAPPY="ON"
+ -DUSE_SYSTEM_ZSTD="ON"
+ -DUSE_DISCORD="$(usex discord)"
+ -DUSE_WAYLAND_WSI="$(usex wayland)"
+ -DUSING_QT_UI="$(usex qt5)"
+ -DUNITTEST="$(usex test)"
+ )
+
+ # TODO: fix with >=ffmpeg-7 then drop compat (bug #948816).
+ # Unfortunately not using pkg-config and needs both flags and dir.
+ ffmpeg_compat_setup 6
+ ffmpeg_compat_add_flags
+ mycmakeargs+=( -DFFMPEG_DIR="${SYSROOT}$(ffmpeg_compat_get_prefix 6)" )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_src_test -E glslang-testsuite
+}