summaryrefslogtreecommitdiff
path: root/games-emulation
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/Manifest.gzbin12065 -> 12072 bytes
-rw-r--r--games-emulation/melonds/Manifest2
-rw-r--r--games-emulation/melonds/melonds-1.0_rc.ebuild92
3 files changed, 94 insertions, 0 deletions
diff --git a/games-emulation/Manifest.gz b/games-emulation/Manifest.gz
index 5eb37c26bcfa..72a0c736e96e 100644
--- a/games-emulation/Manifest.gz
+++ b/games-emulation/Manifest.gz
Binary files differ
diff --git a/games-emulation/melonds/Manifest b/games-emulation/melonds/Manifest
index 6ccd9386ce22..d959438af86d 100644
--- a/games-emulation/melonds/Manifest
+++ b/games-emulation/melonds/Manifest
@@ -1,4 +1,6 @@
DIST melonDS-0.9.5_p20241113.tar.gz 3410057 BLAKE2B 6c4e5e8aa1a519a11308d42168c22d6fde8176fe46e96d00edcc34112e16d65aad77d1925b9f1966c198035cccae092902428081f1cf56d40eac30c369477433 SHA512 25b18547899e18e915cfdc0c437472fb39eeac520c478e232783fc5d57430e84b2cd0be1b2bcddfe9f5132877c8278ebb29893e7a104d7731974aa5e44f79914
+DIST melonds-1.0_rc.gh.tar.gz 3594949 BLAKE2B cb4cc8e8d38bc544084c8a22aeba1a6284ef36ed808a84c890a8bcc946bce3fa27622ef965f48bed2808b12e9727b4df21d1e31b1c8ed0ce1ee9a24955d2de5b SHA512 3b7efe02be2aa058a3364c52f20ee528cea70940f9d81c4db5c936da8bf46226a2eadfa7b65c5acbf0dc8253b8108995cf0b55d79f0c70bf6222ac14c9e6e382
EBUILD melonds-0.9.5_p20241113.ebuild 1819 BLAKE2B 863447bb80d6f1bc9cbc9b3b1052e4d6361572be0ea075711aac7b02d23a40acb448a0d8d90b0c9f9c0af87f7760e4f53252d817d48fd0d5cecfa79500bc4a27 SHA512 4e0bc0860c69b96cf83ba073049fdaa142b8233f55bfe107fb0ebeed8d4534c6d0cb71814df6e5548bb46b94dc641d0bc9563c71cba11d7552162f255bd82536
+EBUILD melonds-1.0_rc.ebuild 1783 BLAKE2B 7dc83b6b84721a6ba33e818d1914920d3088539118c3279eb28c0c2ce34737398be8ae0c7085475f1df5edcca2916b99818a838168b771d6d09c3b22ba51f73e SHA512 e2a2b09a5751dc5cd77c8aae598f076b53bc46a7d76914dce05ad1a41f20310c12256bbc1094edd421b9f4407fac1134021a034aded617f4ce80ace2cad4c356
EBUILD melonds-9999.ebuild 1723 BLAKE2B aea56a4c7b95947df532958dc4e6c9b93168e3abc2d2f979d006642b1922bde3b0e3422d2f72ad0b8d4b07b4d3b4c824e65e307da72534617e5c631e8934ba8c SHA512 5d471a884d3d6c0018d9556e2786ddaa4a8e48499862674d4a8726b2e6d26ac30c2ef753b2c6bf7e3a918425788c9535ac247a6e1ce6749c1b53751de27f7389
MISC metadata.xml 404 BLAKE2B e9abe00b5ee8196030846be4e7a9e224c0fb7356f88a39949b219bb7355bcac50f6ca28b299a40f056e5a105903cb156aed77731fb3ed61d2ef88becf35d0dc3 SHA512 6e2926035441d9c93759ad92cb2c026a10d28b8354e90d56361b4afc1aa6e7f0e4bb49900ad9f6025f8f9b7070df5691583074f30620196f1305919bd7cfdbdb
diff --git a/games-emulation/melonds/melonds-1.0_rc.ebuild b/games-emulation/melonds/melonds-1.0_rc.ebuild
new file mode 100644
index 000000000000..0c99dd96ef21
--- /dev/null
+++ b/games-emulation/melonds/melonds-1.0_rc.ebuild
@@ -0,0 +1,92 @@
+# Copyright 2019-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REAL_PN="melonDS"
+REAL_PV="${PV/_rc/rc}"
+REAL_P="${REAL_PN}-${REAL_PV}"
+
+inherit cmake readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="http://melonds.kuribo64.net
+ https://github.com/Arisotura/melonDS"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Arisotura/${REAL_PN}"
+else
+ SRC_URI="https://github.com/Arisotura/${REAL_PN}/archive/${REAL_PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${REAL_P}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
+SLOT="0"
+IUSE="+jit +opengl wayland"
+
+RDEPEND="
+ app-arch/libarchive[zstd]
+ dev-qt/qtbase:6[network,opengl,widgets]
+ dev-qt/qtmultimedia:6
+ dev-qt/qtsvg:6
+ media-libs/libsdl2[sound,video]
+ net-libs/enet:=
+ net-libs/libpcap
+ net-libs/libslirp
+ x11-libs/libxkbcommon
+ wayland? (
+ dev-libs/wayland
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ wayland? (
+ kde-frameworks/extra-cmake-modules:0
+ )
+"
+
+# Used for JIT recompiler.
+QA_EXECSTACK="usr/bin/melonDS"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need the following files in order to run melonDS:
+- bios7.bin
+- bios9.bin
+- firmware.bin
+- romlist.bin
+Place them in ~/.config/melonDS
+Those files can be extracted from devices or found somewhere on the Internet ;-)"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_SHARED_LIBS="OFF"
+ -DUSE_SYSTEM_LIBSLIRP="ON"
+
+ -DENABLE_JIT="$(usex jit)"
+ -DENABLE_OGLRENDERER="$(usex opengl)"
+ -DENABLE_WAYLAND="$(usex wayland)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
+src_install() {
+ readme.gentoo_create_doc
+ cmake_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}