summaryrefslogtreecommitdiff
path: root/games-emulation
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/Manifest.gzbin12067 -> 12067 bytes
-rw-r--r--games-emulation/stella/Manifest2
-rw-r--r--games-emulation/stella/stella-6.7.1.ebuild74
3 files changed, 0 insertions, 76 deletions
diff --git a/games-emulation/Manifest.gz b/games-emulation/Manifest.gz
index 61998fa63b73..1d65152dd995 100644
--- a/games-emulation/Manifest.gz
+++ b/games-emulation/Manifest.gz
Binary files differ
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
index 777c02062264..e7a41bd3232a 100644
--- a/games-emulation/stella/Manifest
+++ b/games-emulation/stella/Manifest
@@ -1,5 +1,3 @@
-DIST stella-6.7.1-src.tar.xz 10277788 BLAKE2B c40db17c2e91277f3ec4d6db275e9f3c197883888eff44a046fd9405437539f253628777e2230b006ace16105bb2e0d524d86d3b6d3071876d97d190b96dbcb0 SHA512 7ab3c46eb8a1243334222e69a5e6cb33eff18d43f7312f52f660b608dc21992e2c0a0bd43df3a2f1c2a0789e445b960970a866f1f0755edffe2f63ad930a0f3a
DIST stella-7.0-src.tar.xz 13685208 BLAKE2B 817cbb5c3c78d6fa1a38bd2ba4f6f192aa63b67f91fb122df964f6f7fe3f274e2038c12aa81f5217e5c907dd69f5aa8b0f1f2a7b225c8485f3dce4f591bb8242 SHA512 43e31f5f32eeb8241db56c88b6183bd80884d7d0509340dc14e16cc2580ae79079027fbeddcdc11e271b08b9aefbe07e50428724d5097cde4e200b80e6d89f6e
-EBUILD stella-6.7.1.ebuild 1698 BLAKE2B 45b3bb50e22da4d4046101046cd42a195fd53ae9fa217900db147dfa0174d3b234ae9ac21ea6b80fe291622968fdc5f1a01ae1045ab4598023ac1c2514d7f43c SHA512 bc2a59559831312e36d7c63c4e38b56720b6eccd2ea8390093e42b03b7185ee89bbe9d582a1496fcf75280fe7798c20021673208f48981c0c689745d62cc8e1b
EBUILD stella-7.0.ebuild 1346 BLAKE2B 100f34ccf4aa62ac78e406f97e03f7c3c873c6e0ae8f359ef57f73efab09a9b6a4831f2a906893efdd0a1f79e9d1aa6e5839ceebd32ac8f15cf0b7aa1820b659 SHA512 abbac5ae2c9e1bbff0411b93932f1ea0c38642c03ddf5722b692b404acf8d99a4066cac4ac7aba82eb9fce6312109fd809567e8522dd9697d4bfcc3cbcf15fbf
MISC metadata.xml 387 BLAKE2B b0a5ff1a423343613aa6a17767261d65d644401f6945fb7f806363e3cfc291aa68927cc3640db016ca2d4ca1c8d830e9911f115759dd6613b53f2b30f1e6ba4b SHA512 3cdd0d8c089ef1f2635a88204abc739940ab1676699d579e0b2395cd02586d9cb7a4a70bd717724bf9e8a0fea68bccf3dc1060caab180ae6407b013138d6f269
diff --git a/games-emulation/stella/stella-6.7.1.ebuild b/games-emulation/stella/stella-6.7.1.ebuild
deleted file mode 100644
index aad9eed45418..000000000000
--- a/games-emulation/stella/stella-6.7.1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs xdg
-
-DESCRIPTION="Multi-platform Atari 2600 VCS Emulator"
-HOMEPAGE="https://stella-emu.github.io/"
-SRC_URI="https://github.com/stella-emu/stella/releases/download/${PV}/${P}-src.tar.xz"
-
-LICENSE="GPL-2+ BSD MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+joystick png zlib"
-REQUIRED_USE="png? ( zlib )"
-
-RDEPEND="
- dev-db/sqlite:3
- media-libs/libsdl2[joystick?,opengl,sound,video]
- png? ( media-libs/libpng:= )
- zlib? ( sys-libs/zlib:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- default
-
- sed -i 's/pkg-config/${PKG_CONFIG}/' configure || die
- sed -i '/CXXFLAGS+=/s/-fomit-frame-pointer//' Makefile || die
-}
-
-src_configure() {
- tc-export CC CXX PKG_CONFIG
-
- # not autotools-based
- local configure=(
- ./configure
- --host=${CHOST}
- --prefix="${EPREFIX}"/usr
- --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
- $(use_enable joystick)
- $(use_enable png)
- $(use_enable zlib zip)
- ${EXTRA_ECONF}
- )
-
- echo ${configure[*]}
- "${configure[@]}" || die
-}
-
-src_install() {
- local DOCS=(
- Announce.txt Changes.txt README-SDL.txt
- Readme.txt docs/R77_readme.txt Todo.txt
- )
-
- default
-
- rm -- "${ED}"/usr/share/doc/${PF}/html/*.txt || die
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 6.7; then
- elog "With version >=6.7, because of fixes to JSON handling, all remappings"
- elog "will be reset to defaults. If you had custom mappings, they will need"
- elog "to be re-entered again."
- elog
- elog "Furthermore, because of internal changes, all old state files are invalid."
- fi
-}