summaryrefslogtreecommitdiff
path: root/games-emulation
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/Manifest.gzbin12062 -> 12052 bytes
-rw-r--r--games-emulation/mupen64plus-video-glide64mk2/Manifest3
-rw-r--r--games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.9-r2.ebuild26
-rw-r--r--games-emulation/pcsx2/Manifest5
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.5835-vanilla-shaderc.patch49
-rw-r--r--games-emulation/pcsx2/pcsx2-1.7.5835.ebuild175
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild4
7 files changed, 250 insertions, 12 deletions
diff --git a/games-emulation/Manifest.gz b/games-emulation/Manifest.gz
index 4b8d93bf5f7f..7ff1ce1c46ba 100644
--- a/games-emulation/Manifest.gz
+++ b/games-emulation/Manifest.gz
Binary files differ
diff --git a/games-emulation/mupen64plus-video-glide64mk2/Manifest b/games-emulation/mupen64plus-video-glide64mk2/Manifest
index 90baa3112efc..66327bcd4563 100644
--- a/games-emulation/mupen64plus-video-glide64mk2/Manifest
+++ b/games-emulation/mupen64plus-video-glide64mk2/Manifest
@@ -1,3 +1,4 @@
+DIST mupen64plus-video-glide64mk2-2.5.9-boost-1.85.patch 11979 BLAKE2B 5c8b8c839547f5e141a2a2def5b0afc3c69aba84cc7cf65cb447ccc29f91e6e02aa7fb2d30f635f8f7e36e21e4b8cbeffac2301aceb021b09064631dd42b94bd SHA512 239120ce13343bb4d0fe8031db893b873fccebfe60926a41b2d5af94b376ba4ef79292c645d14eba50ef433e33d4fea538a46ded6ef3c2c2017c4efe83d55fa6
DIST mupen64plus-video-glide64mk2-src-2.5.9.tar.gz 498350 BLAKE2B 8378cfc9fe624b3441e290d44d600e30a85393aca5a5a5867fb778a665ea0718ae15ba67ce5b62930cd4feffb7b1ddce88be6434de9791c82a979aa8f022ecd1 SHA512 cc4cce1a1f036cdda0748cf9eb758f21ba08dbe83a2844cf92d3e781102aaa3556934ca01dbae248a2d93c65209932b858988030beaa29395d79df70bf479bd4
-EBUILD mupen64plus-video-glide64mk2-2.5.9-r2.ebuild 2054 BLAKE2B ffd0ccbf980545a52127e47c9e7e631489e0489be7a5e551efd06e551f5e843c86e3c7512040c4cd65d2d2a89b4780e59c2b708ebdc7a51391ec8badfab29abd SHA512 63f5a3bc530512b08a0c998baf93b8512ada994483bb51b1dbe8109fe624fbe8c605288c10c2334f02a1551c6ad98d433e7ee72b45c77ff6cd8bb39739c9f1c4
+EBUILD mupen64plus-video-glide64mk2-2.5.9-r2.ebuild 2358 BLAKE2B eb1a2f7614b92159b4d96bc415d8c46f12a82b38fb5fdf568fd237b41dd0f7dd4464e640f03c0f8654a8523ac9f3118abe66ee563a66b4d46c118a50bc1113c9 SHA512 837df8b2e715ac01bc42801448ab3ba77b47d38ec3e42a8e89f83acfdea92cea4f11b39e3b05e58caabec3fc96255f6a96afb7885f601304f66f77952e7cf8c4
MISC metadata.xml 464 BLAKE2B a7d00e92b0189adda8e6099554f6ee905fd8908df934fa6c61d59d32db5a414aa2ab466bfcae36e805e06370c6644a25307ceb154b02c3308e92661abd76c631 SHA512 c9dba0b8a42f245269c2e0dc6ff6c5640e3cee9bba19ffd0f2b949625e668fd77963a91a11765e4dc7fb30ca0b819dcf07cfe3d802444e9b89dbd3d19cd975e8
diff --git a/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.9-r2.ebuild b/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.9-r2.ebuild
index d0d4d129fb2a..f7f838337371 100644
--- a/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.9-r2.ebuild
+++ b/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.9-r2.ebuild
@@ -1,14 +1,19 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-MY_P=${PN}-src-${PV}
inherit toolchain-funcs
+MY_P=${PN}-src-${PV}
DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, glide64mk2 video plugin"
HOMEPAGE="https://www.mupen64plus.org/"
-SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+SRC_URI="
+ https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz
+ https://github.com/mupen64plus/mupen64plus-video-glide64mk2/commit/b44b0d1c439bae1cf6c334711ef1ea4d2b565053.patch
+ -> ${P}-boost-1.85.patch
+"
+S=${WORKDIR}/${MY_P}
# TODO: 3dfx licenses
LICENSE="GPL-2+"
@@ -16,21 +21,26 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gles2-only hires cpu_flags_x86_sse"
-RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=[gles2-only=]
+DEPEND="
+ >=games-emulation/mupen64plus-core-2.5:0=[gles2-only=]
media-libs/libpng:0=
media-libs/libsdl2:0=[video]
sys-libs/zlib:0=
virtual/opengl:0=
gles2-only? ( media-libs/libsdl2:0[gles2] )
- hires? ( dev-libs/boost:= )"
-DEPEND="${RDEPEND}"
+ hires? ( dev-libs/boost:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
BDEPEND="virtual/pkgconfig"
-S=${WORKDIR}/${MY_P}
-
src_prepare() {
default
+ # https://github.com/mupen64plus/mupen64plus-video-glide64mk2/commit/b44b0d1c439bae1cf6c334711ef1ea4d2b565053
+ eapply "${DISTDIR}/${P}-boost-1.85.patch"
+
# avoid implicitly appending CPU flags
sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
}
diff --git a/games-emulation/pcsx2/Manifest b/games-emulation/pcsx2/Manifest
index 026dd231102a..05e9b2dcd867 100644
--- a/games-emulation/pcsx2/Manifest
+++ b/games-emulation/pcsx2/Manifest
@@ -2,9 +2,12 @@ AUX pcsx2-1.7.4667-flags.patch 333 BLAKE2B 4c986ba4909c7289362665c95806bb0730600
AUX pcsx2-1.7.5232-cubeb-automagic.patch 774 BLAKE2B a932e49643df613710c27c8f0881c6e2b9c2d90964ff7f88b48b3ec5ad281bbd152fbede638accc054ea5935401ef240ed0bf8107fe1c10997242ea546b93699 SHA512 5985f08a2acce8ccbe946a7c5bd85b2388ad7166b0243a7e698c96990a3856660c1f353bc74a9ced0e5ff08f10e27922e05eb77fabff1e797166b7d6a4c445a7
AUX pcsx2-1.7.5700-vanilla-shaderc.patch 751 BLAKE2B d7dde7c368c2231b2876d1e42ae1306f413bcc795a15514e3cbe15bedccc667a60d9ac09b8559ee48513fb144732937bc69e5d722523fb6a3353adebd7ae8464 SHA512 975d490772a7552f748afbc37fddb7acbd3b33e58799b0b4527b24b6d7335436739e8c544a1eee4c73240029a5bd691e318e953c1d9a33e0630061d69a038837
AUX pcsx2-1.7.5817-missing-headers.patch 452 BLAKE2B 38b873c62a9cf7fe9e7e7357d7a5253ec4cc8532823e08babb8a17ddc03b097d7b170d6b02a7ffb88615a56b4669170980e93aebb22510bb087d83724972d102 SHA512 af6aaa4985e822a859fe65bc9f33f3b3ecc0c3a0c49fbe466d5351366c4bd32438650378db29fe8bbd4d2a72221de61ef61eb226ccfd736123c4eb38cf0d1226
+AUX pcsx2-1.7.5835-vanilla-shaderc.patch 2637 BLAKE2B 87a0774d44ad6d9b8f5219fbb2c36f4156bbefdeb172b6cca5ac6d310ab569e1687202b97b3056220fd0d5cacd0da1dbb11dcd6912b7d53850fbd0e419d13485 SHA512 1d624fae87b92c509404b0a27218a82163568350f223dbd2d9a2021d5207b923bdf9f7e13d5c6efd89aaea6eeb021ee825dce9be0a389ba0b5ee2adfa4a48c16
DIST pcsx2-1.7.5624.tar.xz 18073460 BLAKE2B 3068190f979cb5d04c7e8bd89cbab2953bff90c90c0b1fa5e8c1e0ca50eef8b557110c14a61b6f9b9bf5262e5c5151ff0a0a017fed65b63b62d86fd80fd69cdd SHA512 60720289a0994d82d57961be257a89ac12055eefc31fdc0b1f08e4918be4e76a907884c0541c71ea3091467b7c293177dd53445811c1b68037852dfd3e1589f6
DIST pcsx2-1.7.5724.tar.xz 11429708 BLAKE2B 773dddc2b754ec5eddccad6e520846811299aac9cddf7b5ab77cca13c330f457f2b1d045d5f0f804a70d7fd3e498b6aab62b32e0a58536afd6805785055c81c4 SHA512 1589a0f3087cbb7c57e648f7afc7f1a22edef2601bab10dec2928b31d77d81780f11916f5a56f353d4a1063ea7e01e6ddab8df9e4982424eb7cf14b3bcfe2e3d
+DIST pcsx2-1.7.5835.tar.xz 11565084 BLAKE2B 537aa890b668a1bed471f3677de1fee99f33fda41943dc4e7a11f8a85d2cbe831bfcd0040319643d370e90f31974272ee8ec4e17e3b6ec5d170d5750d38d707f SHA512 7e0541e5d0433a59047dfd15af3c3d90c61f61a416510cce14b89d5b641c45d7deae1a084ebd9e8b36f1768e714e3b480f1b28801e0f818b0290d7d06d384bc7
EBUILD pcsx2-1.7.5624.ebuild 4444 BLAKE2B 3602c1506b01d5fc22680968361fc3851d5495f22e0f6669023269d216ac8da017188afc93354cacfcb19b82f58e89bdb31e40d2ff13831930e4431cb3e01068 SHA512 4e03cfa18b447568e0af437763ce03701414270eabd330e9711a736c6470ed51737e4808754ee8dbb9bcc0f1934cae542fb44164083926ea774c8c7350f14594
EBUILD pcsx2-1.7.5724.ebuild 4658 BLAKE2B 0d2fc97197fda74d235b9f653992f0a56ae300510e71b20ddfbc641af68d94c44b25fc3a4abebe7169eb439fd050801137c5f8b7f9a5026279a55bb9d740b3c5 SHA512 f83dcae5a4c7a1699283abef12948ecada3fca29567a58b233384dfa12d870e3b15430a3605d08fcf4ce8cd83df1269da03dc0206d85bc6fbb1c9ce6241838d5
-EBUILD pcsx2-9999.ebuild 4977 BLAKE2B f0cab44371e9ea0a4986d2953c511367bc755f9f6f78f4d6c71ffe98fbae459aa939df8e4f6ce3ef186812c3bed3ea8dc98cc2ba1560e10fb26d562d8b9b8679 SHA512 7f6eaa6376fb836b8116bdfeb8285843d1e0bbca2035c3a8f0439ad45a4aa09678caa55dfe04e8833fab361f404f7ed0e77c0976aa63168e27c69ad52ce28d9b
+EBUILD pcsx2-1.7.5835.ebuild 4986 BLAKE2B e9eeba8d6a984bcecbc5d6a369d0f206eaa2f9367ea526653e1da68f1943da7642066c509091ec79450df11d88f93120a182da449d35a4e0f6da3a6b3a4e35ff SHA512 b15cdc481a0462a92b38e88f2710297a678b58e225467e2b08dce682072f13ff127b960012416c326de56ce4715418c3ddaf84b6a18295a93a8c29be629f4214
+EBUILD pcsx2-9999.ebuild 4986 BLAKE2B e9eeba8d6a984bcecbc5d6a369d0f206eaa2f9367ea526653e1da68f1943da7642066c509091ec79450df11d88f93120a182da449d35a4e0f6da3a6b3a4e35ff SHA512 b15cdc481a0462a92b38e88f2710297a678b58e225467e2b08dce682072f13ff127b960012416c326de56ce4715418c3ddaf84b6a18295a93a8c29be629f4214
MISC metadata.xml 926 BLAKE2B 0076f5137c48d1d000eeff8f82457dfbf01c02928cc2a97479fcdef1eb71ce79c444ece7db8cc949e9c1f143b46623cae5992b51c27be87cf8bbe2bea254a499 SHA512 9e23b0c991418f8c8331795477ece481e0d8a78f4da06db03738cfa303555b80f1bc772f9d521674574fb500cf742b1c5193a0b6084b34f8b16c1cd2f1d33332
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.5835-vanilla-shaderc.patch b/games-emulation/pcsx2/files/pcsx2-1.7.5835-vanilla-shaderc.patch
new file mode 100644
index 000000000000..e9c06fb07a5c
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.5835-vanilla-shaderc.patch
@@ -0,0 +1,49 @@
+PCSX2 upstream modifies shaderc[1][2][3] rendering its code incompatible
+with vanilla. We'd rather not package this modified shaderc if it can
+reasonably be avoided, so this does minimal code changes to allow vanilla
+usage.
+
+Disclaimer: as the author of this patch, be warned that I can hardly claim
+to know neither C++ nor shaderc, so it could very well be wrong. If run into
+vulkan/shaderc-related issues, try to reproduce with upstream's AppImage
+before reporting bugs to them as they offer no support for distros' builds.
+
+[1] https://github.com/PCSX2/pcsx2/commit/1cd4ba269854646
+[2] https://github.com/PCSX2/pcsx2/commit/fbfdf1200d27260
+[3] https://github.com/PCSX2/pcsx2/commit/ff7995f0d6caaac
+
+Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
+--- a/pcsx2/GS/Renderers/Vulkan/VKShaderCache.cpp
++++ b/pcsx2/GS/Renderers/Vulkan/VKShaderCache.cpp
+@@ -109,5 +109,5 @@
+ X(shaderc_compile_options_set_optimization_level) \
+ X(shaderc_compile_options_set_target_env) \
+- X(shaderc_compilation_status_to_string) \
++ X(shaderc_result_get_compilation_status) \
+ X(shaderc_compile_into_spv) \
+ X(shaderc_result_release) \
+@@ -217,19 +217,16 @@
+ dyn_shaderc::shaderc_compile_options_set_source_language(options, shaderc_source_language_glsl);
+ dyn_shaderc::shaderc_compile_options_set_target_env(options, shaderc_target_env_vulkan, 0);
+- dyn_shaderc::shaderc_compile_options_set_generate_debug_info(options, debug,
+- debug && GSDeviceVK::GetInstance()->GetOptionalExtensions().vk_khr_shader_non_semantic_info);
++ dyn_shaderc::shaderc_compile_options_set_generate_debug_info(options);
+ dyn_shaderc::shaderc_compile_options_set_optimization_level(
+ options, debug ? shaderc_optimization_level_zero : shaderc_optimization_level_performance);
+
+- shaderc_compilation_result_t result;
+- const shaderc_compilation_status status = dyn_shaderc::shaderc_compile_into_spv(
++ shaderc_compilation_result_t result = dyn_shaderc::shaderc_compile_into_spv(
+ dyn_shaderc::s_compiler, source.data(), source.length(), static_cast<shaderc_shader_kind>(stage), "source",
+- "main", options, &result);
+- if (status != shaderc_compilation_status_success)
++ "main", options);
++ if (dyn_shaderc::shaderc_result_get_compilation_status(result) != shaderc_compilation_status_success)
+ {
+ const std::string_view errors(result ? dyn_shaderc::shaderc_result_get_error_message(result) :
+ "null result object");
+- ERROR_LOG("Failed to compile shader to SPIR-V: {}\n{}",
+- dyn_shaderc::shaderc_compilation_status_to_string(status), errors);
++ ERROR_LOG("Failed to compile shader to SPIR-V: {}", errors);
+ DumpBadShader(source, errors);
+ }
diff --git a/games-emulation/pcsx2/pcsx2-1.7.5835.ebuild b/games-emulation/pcsx2/pcsx2-1.7.5835.ebuild
new file mode 100644
index 000000000000..295c925c4305
--- /dev/null
+++ b/games-emulation/pcsx2/pcsx2-1.7.5835.ebuild
@@ -0,0 +1,175 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop fcaps flag-o-matic optfeature toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PCSX2/pcsx2.git"
+else
+ # unbundling on this package has become unmaintainable and, rather than
+ # handle submodules separately, using a tarball that includes them
+ SRC_URI="https://dev.gentoo.org/~ionen/distfiles/${P}.tar.xz"
+ KEYWORDS="-* ~amd64"
+fi
+
+DESCRIPTION="PlayStation 2 emulator"
+HOMEPAGE="https://pcsx2.net/"
+
+LICENSE="
+ GPL-3+ Apache-2.0 BSD BSD-2 BSD-4 Boost-1.0 CC0-1.0 GPL-2+
+ ISC LGPL-2.1+ LGPL-3+ MIT OFL-1.1 ZLIB public-domain
+"
+SLOT="0"
+IUSE="alsa cpu_flags_x86_sse4_1 +clang jack pulseaudio sndio test vulkan wayland"
+REQUIRED_USE="cpu_flags_x86_sse4_1" # dies at runtime if no support
+RESTRICT="!test? ( test )"
+
+# dlopen: libglvnd, qtsvg, shaderc, vulkan-loader, wayland
+COMMON_DEPEND="
+ app-arch/lz4:=
+ app-arch/zstd:=
+ dev-qt/qtbase:6[concurrent,gui,widgets]
+ dev-qt/qtsvg:6
+ media-libs/freetype
+ media-libs/libglvnd[X]
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/libsdl2[haptic,joystick]
+ media-libs/libwebp:=
+ media-video/ffmpeg:=
+ net-libs/libpcap
+ net-misc/curl
+ sys-apps/dbus
+ sys-libs/zlib:=
+ virtual/libudev:=
+ x11-libs/libXrandr
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ pulseaudio? ( media-libs/libpulse )
+ sndio? ( media-sound/sndio:= )
+ vulkan? (
+ media-libs/shaderc
+ media-libs/vulkan-loader
+ )
+ wayland? ( dev-libs/wayland )
+"
+# patches is a optfeature but always pull given PCSX2 complaints if it
+# is missing and it is fairly small (installs a ~1.5MB patches.zip)
+RDEPEND="
+ ${COMMON_DEPEND}
+ >=games-emulation/pcsx2_patches-0_p20230917
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-qt/qttools:6[linguist]
+ clang? ( sys-devel/clang:* )
+ wayland? (
+ dev-util/wayland-scanner
+ kde-frameworks/extra-cmake-modules
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.4667-flags.patch
+ "${FILESDIR}"/${PN}-1.7.5232-cubeb-automagic.patch
+ "${FILESDIR}"/${PN}-1.7.5817-missing-headers.patch
+ "${FILESDIR}"/${PN}-1.7.5835-vanilla-shaderc.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ if [[ ${PV} != 9999 ]]; then
+ sed -e '/set(PCSX2_GIT_TAG "")/s/""/"v'${PV}'"/' \
+ -i cmake/Pcsx2Utils.cmake || die
+ fi
+
+ # relax Qt6 and SDL2 version requirements which often get restricted
+ # without a specific need, please report a bug to Gentoo (not upstream)
+ # if a still-available older version is really causing issues
+ sed -e '/find_package(\(Qt6\|SDL2\)/s/ [0-9.]*//' \
+ -i cmake/SearchForStuff.cmake || die
+}
+
+src_configure() {
+ # note that upstream only supports clang and ignores gcc issues, e.g.
+ # https://github.com/PCSX2/pcsx2/issues/10624#issuecomment-1890326047
+ # (CMakeLists.txt also gives a big warning if compiler is not clang)
+ if use clang && ! tc-is-clang; then
+ local -x CC=${CHOST}-clang CXX=${CHOST}-clang++
+ strip-unsupported-flags
+ fi
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=no
+ -DDISABLE_ADVANCE_SIMD=yes
+ -DENABLE_TESTS=$(usex test)
+ -DUSE_LINKED_FFMPEG=yes
+ -DUSE_VTUNE=no
+ -DUSE_VULKAN=$(usex vulkan)
+
+ # note that upstream hardly support native wayland, may or may not work
+ # https://github.com/PCSX2/pcsx2/pull/10179
+ -DWAYLAND_API=$(usex wayland)
+ # not optional given libX11 is hard-required either way and upstream
+ # seemingly has no intention to drop the requirement at the moment
+ # https://github.com/PCSX2/pcsx2/issues/11149
+ -DX11_API=yes
+
+ # not packaged due to bug #885471, but still disable for no automagic
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libbacktrace=yes
+
+ # bundled cubeb flags, see media-libs/cubeb and cubeb-automagic.patch
+ -DCHECK_ALSA=$(usex alsa)
+ -DCHECK_JACK=$(usex jack)
+ -DCHECK_PULSE=$(usex pulseaudio)
+ -DCHECK_SNDIO=$(usex sndio)
+ -DLAZY_LOAD_LIBS=no
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build unittests
+}
+
+src_install() {
+ insinto /usr/lib/${PN}
+ doins -r "${BUILD_DIR}"/bin/.
+
+ fperms +x /usr/lib/${PN}/pcsx2-qt
+ dosym -r /usr/lib/${PN}/pcsx2-qt /usr/bin/${PN}
+
+ newicon bin/resources/icons/AppIconLarge.png ${PN}.png
+ make_desktop_entry ${PN} ${PN^^}
+
+ dodoc README.md bin/docs/{Debugger.pdf,GameIndex.pdf,debugger.txt}
+
+ use !test || rm "${ED}"/usr/lib/${PN}/*_test || die
+}
+
+pkg_postinst() {
+ fcaps -m 0755 cap_net_admin,cap_net_raw=eip usr/lib/${PN}/pcsx2-qt
+
+ # calls aplay or gst-play/launch-1.0 as fallback
+ # https://github.com/PCSX2/pcsx2/issues/11141
+ optfeature "UI sound effects support" \
+ media-sound/alsa-utils \
+ media-libs/gst-plugins-base:1.0
+
+ if [[ ${REPLACING_VERSIONS##* } ]] &&
+ ver_test ${REPLACING_VERSIONS##* } -lt 1.7; then
+ elog ">=${PN}-1.7 has received several changes since <=${PN}-1.6.0, and is"
+ elog "notably now a 64bit build using Qt6. Just-in-case it is recommended"
+ elog "to backup configs, save states, and memory cards before using."
+ elog
+ elog "The executable was also renamed from 'PCSX2' to 'pcsx2'."
+ fi
+}
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 643fe6a2b122..295c925c4305 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -27,7 +27,7 @@ IUSE="alsa cpu_flags_x86_sse4_1 +clang jack pulseaudio sndio test vulkan wayland
REQUIRED_USE="cpu_flags_x86_sse4_1" # dies at runtime if no support
RESTRICT="!test? ( test )"
-# dlopen: libglvnd, qtsvg, vulkan-loader, wayland
+# dlopen: libglvnd, qtsvg, shaderc, vulkan-loader, wayland
COMMON_DEPEND="
app-arch/lz4:=
app-arch/zstd:=
@@ -78,8 +78,8 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-1.7.4667-flags.patch
"${FILESDIR}"/${PN}-1.7.5232-cubeb-automagic.patch
- "${FILESDIR}"/${PN}-1.7.5700-vanilla-shaderc.patch
"${FILESDIR}"/${PN}-1.7.5817-missing-headers.patch
+ "${FILESDIR}"/${PN}-1.7.5835-vanilla-shaderc.patch
)
src_prepare() {