summaryrefslogtreecommitdiff
path: root/games-emulation/ppsspp/ppsspp-1.15.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/ppsspp/ppsspp-1.15.4.ebuild')
-rw-r--r--games-emulation/ppsspp/ppsspp-1.15.4.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/games-emulation/ppsspp/ppsspp-1.15.4.ebuild b/games-emulation/ppsspp/ppsspp-1.15.4.ebuild
index 653f672374ea..17b358731669 100644
--- a/games-emulation/ppsspp/ppsspp-1.15.4.ebuild
+++ b/games-emulation/ppsspp/ppsspp-1.15.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,8 +15,8 @@ SRC_URI="https://github.com/hrydgard/${PN}/releases/download/v${PV}/${P}.tar.xz"
LICENSE="Apache-2.0 BSD BSD-2 GPL-2 JSON MIT"
SLOT="0"
KEYWORDS="amd64"
-IUSE="discord qt5"
-RESTRICT="test"
+IUSE="discord qt5 test"
+RESTRICT="!test? ( test )"
RDEPEND="
app-arch/snappy:=
@@ -43,6 +43,7 @@ BDEPEND="${PYTHON_DEPS}"
PATCHES=(
"${FILESDIR}"/${PN}-CMakeLists-flags.patch
"${FILESDIR}"/${PN}-disable-ccache-autodetection.patch
+ "${FILESDIR}"/${PN}-1.15.4-backport-ce83fec.patch
)
pkg_setup() {
@@ -60,6 +61,11 @@ src_configure() {
-DUSE_SYSTEM_ZSTD=ON
-DUSE_DISCORD=$(usex discord)
-DUSING_QT_UI=$(usex qt5)
+ -DUNITTEST=$(usex test)
)
cmake_src_configure
}
+
+src_test() {
+ cmake_src_test -E glslang-testsuite
+}