summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/pcsx2')
-rw-r--r--games-emulation/pcsx2/Manifest2
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild7
2 files changed, 6 insertions, 3 deletions
diff --git a/games-emulation/pcsx2/Manifest b/games-emulation/pcsx2/Manifest
index c9366e8acda3..94029182cf7b 100644
--- a/games-emulation/pcsx2/Manifest
+++ b/games-emulation/pcsx2/Manifest
@@ -18,5 +18,5 @@ DIST pcsx2-vulkan-headers-9f4c61a314.tar.gz 1554220 BLAKE2B 7f7fa093e8af30919dd7
EBUILD pcsx2-1.6.0-r3.ebuild 2647 BLAKE2B 7d7a0e595d3d8297f3ae0049b3c376f404eeb5a6f477486076e5ac2b72dae6065c97b845f715f4e7e52af158b9dfbe6bbc5cf4f10d051838eafe44553f76efd3 SHA512 18b6131c6ff0b292f4dde4a54b4a5c698a403860ab332e01f181e18931e5ac14cc131ce140de563125f63eeb8b3523b51c6df4f4ecf2086a00e000d4e3d0289b
EBUILD pcsx2-1.7.3738.ebuild 7179 BLAKE2B 5961ab90cba0d1890d81aefb79306f87a6c58eb81e4d748bc9264d7e5cd32c463dbe0c98a8220453a752c4e420e7df6c3e977373682565bbaac994deb90aaae6 SHA512 b1caa95f1ee816b946db25bd9559ccb29a68f0550b728ffe012b9ecb4d541b2fa763ec7aa7007df30bc6580a77bdafb52a6dcbe1d4b754037da3b120b646cec9
EBUILD pcsx2-1.7.3820.ebuild 7506 BLAKE2B 647d549dbe57a31e2504fc982d1f6af8bace1b3504cb0e4dc92b791b8726d658dd984c264eb8f1dc25dfae7d57534e2bd03708fffb86dafb5579cf1d8ee28f33 SHA512 b1a5354c7129eac81e12c4d23ba6484acb88e7cd367ea71636fc0181fce8539c4b726c04d5cc126aa60ec10188cc0290f0c5bd34b521a1ccba46673247bdc9bb
-EBUILD pcsx2-9999.ebuild 7519 BLAKE2B ff64d38d022b31ef6216ea62bb5d8744a080405edd19cbedd0d01b3143116fa02c631b00f19a513712c2955e4bfea39b3f06d4809469c14e7b718b43e3b60888 SHA512 f22f5259cedc01df02e4a55a805dfc619a2765a780272a91c0fd00bc154dc8d73835c5c0834ba4b3e85ee7d6a15fcd1c39155ee11d66db80ba3959e70e73e56e
+EBUILD pcsx2-9999.ebuild 7666 BLAKE2B d357051308e21de89a26a2865cc0783dcfd8f368ccc9000befbd713f4249fcd9a61f15f12a04f8c2d4f60b080906ef0e25d6b130cf55dfaedd4995b6bdb5a555 SHA512 51848ba98bc8ac7ac3e8a8204d92c0a7e490c369cf1da2b436c136e899bf8342fbed8157062c1b10f0d5007553b2daafb417ba845eb722cca33f18a3d2d30795
MISC metadata.xml 805 BLAKE2B eb7ce944f7dc5b1889cc2b59f389eafabe9d5e44c4a730fa1352b0a00aec0f97d607204c440a9ce014e02f5b1a73c6ccd294074e7ce41f563c6c3643614ac9f6 SHA512 e8d939f76830204283557319961b4e3aab557e1c3e36fbfc98d4605b0728adb42d0731a05da998eb099f6b0df837eef7616cddb1e62b006979fb9262c172d961
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index b9d68d63b68b..e2f804a6b008 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -161,13 +161,17 @@ src_configure() {
-DDISABLE_BUILD_DATE=yes
-DDISABLE_SETCAP=yes
-DENABLE_TESTS=$(usex test)
- -DUSE_SYSTEM_LIBS=yes
-DUSE_VTUNE=no
-DUSE_VULKAN=$(usex vulkan)
-DWAYLAND_API=$(usex wayland)
-DX11_API=yes # fails if X libs are missing even if disabled
-DXDG_STD=yes
+ # note that the current upstream is somewhat hostile to using system
+ # libs, system installs, or any modifications and may disregard any
+ # bugs that is not reproducible with the appimage using bundled libs
+ -DUSE_SYSTEM_LIBS=yes
+
# sse4.1 is the bare minimum required, -m is required at build time
# (see PCSX2Base.h) and it dies if no support at runtime (AppInit.cpp)
# https://github.com/PCSX2/pcsx2/pull/4329
@@ -189,7 +193,6 @@ src_test() {
}
src_install() {
- # package mode was removed turning cmake_src_install into a noop
newbin "${BUILD_DIR}"/pcsx2-qt/pcsx2-qt ${PN}
insinto /usr/share/${PN}