summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2/files/pcsx2-1.7.3329-lto.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/pcsx2/files/pcsx2-1.7.3329-lto.patch')
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.3329-lto.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.3329-lto.patch b/games-emulation/pcsx2/files/pcsx2-1.7.3329-lto.patch
new file mode 100644
index 000000000000..1047105d646a
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.3329-lto.patch
@@ -0,0 +1,21 @@
+Lazy fix for -Werror=odr and don't rely on the CMAKE macro to
+pass -fno-lto to the problematic FastJmp.cpp source with lto.
+--- a/common/CMakeLists.txt
++++ b/common/CMakeLists.txt
+@@ -268,3 +268,3 @@
+
+-if (USE_GCC AND CMAKE_INTERPROCEDURAL_OPTIMIZATION)
++if (USE_GCC)
+ # GCC LTO doesn't work with asm statements
+--- a/pcsx2/PAD/Linux/Device.h
++++ b/pcsx2/PAD/Linux/Device.h
+@@ -31,3 +31,3 @@
+
+-enum DeviceType
++enum PADDeviceType
+ {
+@@ -101,3 +101,3 @@
+ DeviceAPI api;
+- DeviceType type;
++ PADDeviceType type;
+