summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch')
-rw-r--r--games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch b/games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch
new file mode 100644
index 000000000000..c14491e70496
--- /dev/null
+++ b/games-emulation/mupen64plus-ui-console/files/mupen64plus-ui-console-2.5.9-fix-makefile.patch
@@ -0,0 +1,32 @@
+--- a/projects/unix/Makefile
++++ b/projects/unix/Makefile
+@@ -94,7 +94,7 @@
+ ifeq ($(ARCH_DETECTED), 64BITS)
+ CFLAGS += -pipe -arch x86_64 -mmacosx-version-min=10.6 -isysroot $(OSX_SDK_PATH)
+ else
+- CFLAGS += -pipe -mmmx -msse -fomit-frame-pointer -arch i686 -mmacosx-version-min=10.6 -isysroot $(OSX_SDK_PATH)
++ CFLAGS += -pipe -arch i686 -mmacosx-version-min=10.6 -isysroot $(OSX_SDK_PATH)
+ endif
+ endif
+ endif
+@@ -172,20 +172,6 @@
+ COMPILE.c = $(Q_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(TARGET_ARCH) -c
+ LINK.o = $(Q_LD)$(CC) $(CFLAGS) $(LDFLAGS) $(TARGET_ARCH)
+
+-ifeq ($(PIE), 1)
+- CFLAGS += -fPIE
+- LDFLAGS += -pie
+-else
+- CFLAGS += -fno-PIE
+- ifeq ($(CC),$(CROSS_COMPILE)gcc)
+- # check if PIE is the default for the compiler
+- PIE_DEFAULT = $(shell $(CC) -v 2>&1 | grep enable-default-pie)
+- ifneq ($(PIE_DEFAULT),)
+- LDFLAGS += -no-pie
+- endif
+- endif
+-endif
+-
+ # set installation options
+ ifeq ($(PREFIX),)
+ PREFIX := /usr/local