summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-input-sdl
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/mupen64plus-input-sdl')
-rw-r--r--games-emulation/mupen64plus-input-sdl/Manifest4
-rw-r--r--games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.9.ebuild76
-rw-r--r--games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild2
3 files changed, 80 insertions, 2 deletions
diff --git a/games-emulation/mupen64plus-input-sdl/Manifest b/games-emulation/mupen64plus-input-sdl/Manifest
index 6def5f917f8a..62d6b95b9934 100644
--- a/games-emulation/mupen64plus-input-sdl/Manifest
+++ b/games-emulation/mupen64plus-input-sdl/Manifest
@@ -1,3 +1,5 @@
+DIST mupen64plus-input-sdl-src-2.5.9.tar.gz 56403 BLAKE2B 56d6c390783aa4a7f25f72a5295eb11f1ca2a69f2ffe4f0232d4a0c329e9c0eba0a2cbf46e66adfdf0462d2ec5337f7c6c4587ae29de346cd4cfe1d240f4d5fd SHA512 b613396ee05e82aaaf15e955f83b5cb4e854df1fdb34d5e1c96cf0fddf0af79aa5af2ceb19cc9cfeaef707c2ecafd25e0814e3d7715a20b740482d0ece273f2f
DIST mupen64plus-input-sdl-src-2.5.tar.gz 50580 BLAKE2B ab75c6e200c2979c75d35082a426266e7f835e0731058f8013d8788802ab9d65363b8820326fbfedc0b384facfaeccf6e04da66e01f79aee3d420f3ebe385461 SHA512 014a5e21feb88b14bcee44a74556a257393b799745308421a611eb3b6c11a390a589fdd393f07e69a128ca60426d4dcf8847bcbabed77b0d570be282550148d6
-EBUILD mupen64plus-input-sdl-2.5.ebuild 1681 BLAKE2B 5eb74028c1914c4057e43fbb5a195111f22a9593db41519ebe7a189d4264791ccb8b3672c79b9f60f5923c50e6c8209c6dd9fb93b12c989058a395c649a5a0db SHA512 42ac79a06506801717db1692bc86813a5737ebafceebfa1e498cd0bef25abc58fe55b28897230a70cdf870ec01e80f079203f4ed2618055e2b820f8163177e46
+EBUILD mupen64plus-input-sdl-2.5.9.ebuild 1672 BLAKE2B 867836b469fec24a8884902f0cdf97fdad027e34d529c03312c0b86f32b36fff9e1545c3ba5ad19d236a2a923300315a8ec3a146f2a773427b6b09a4dbcafba9 SHA512 4443ea7c6e39cafc3cb718d70009a492026881bcc014deb613f731f7498e96b9193f7a7204138339ba444912903b8c4e72cb4889806c55af2dd6545bb562905f
+EBUILD mupen64plus-input-sdl-2.5.ebuild 1682 BLAKE2B 15e640c764d7e9ba7ec4db91e3095264791c92a78eb69dc8bbf201af0bdf19508afb2e9f1312566829475ee872fef31ed6b739ae77d8557825d2de5b30c2b2c6 SHA512 5e3dbf701b1d4203f292052d2a599f48cd1f8cb6ad2dd5f4f9ae4f0247efe08a1be15b800609a6aad7a4ac2d96aff28c1d73670143628b631d483bae23c0aed0
MISC metadata.xml 345 BLAKE2B ad9e66275eecd48b36aea9d14bea0b3651adcafdccc82542761d9c8bf2636f2c56f31b7d4e451bbdf0108de016d923b998f59a4ed774a2becb1cde66bf95dd01 SHA512 52f335099ec233825167226c8c15e6b270820eb111c8b89bcb91a4606f7b1d1d79ed12f41ac5ee69d973137c618f038ff55e395097fb1f1517692083ca86c294
diff --git a/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.9.ebuild b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.9.ebuild
new file mode 100644
index 000000000000..3d9194e5df20
--- /dev/null
+++ b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.9.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${PN}-src-${PV}
+inherit toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL input plugin"
+HOMEPAGE="https://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=games-emulation/mupen64plus-core-${PV}:0=
+ media-libs/libsdl2:0=[joystick]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ dodoc AUTHORS README.md RELEASE
+}
diff --git a/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild
index fe28b341357a..dd085bd0c45f 100644
--- a/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild
+++ b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild
@@ -7,7 +7,7 @@ MY_P=${PN}-src-${PV}
inherit eutils multilib toolchain-funcs
DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL input plugin"
-HOMEPAGE="http://www.mupen64plus.org/"
+HOMEPAGE="https://www.mupen64plus.org/"
SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"