summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-audio-sdl
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/mupen64plus-audio-sdl')
-rw-r--r--games-emulation/mupen64plus-audio-sdl/Manifest4
-rw-r--r--games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.9.ebuild84
-rw-r--r--games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild2
3 files changed, 88 insertions, 2 deletions
diff --git a/games-emulation/mupen64plus-audio-sdl/Manifest b/games-emulation/mupen64plus-audio-sdl/Manifest
index 5178a9a602a2..cd1ea8ce52ce 100644
--- a/games-emulation/mupen64plus-audio-sdl/Manifest
+++ b/games-emulation/mupen64plus-audio-sdl/Manifest
@@ -1,3 +1,5 @@
+DIST mupen64plus-audio-sdl-src-2.5.9.tar.gz 28884 BLAKE2B a32aeff100e86f610e3b514718c6a4a786c6f88911f8782dcbc9b8a2d238c31984e5d119e31533363d8f848bf840ff7350ba41dea70e716d50cce14f2398c836 SHA512 624f7061b4909a5de071fbb8cf6432fd4b6ad390ea3f7dc7ae7a874dc922afee55352e53d48fba43d45a3282e9382e6b5774814c2a7d9724e134a01188596ea9
DIST mupen64plus-audio-sdl-src-2.5.tar.gz 26147 BLAKE2B bcd0c76d1e4fffb55940889c329574760101177c7cc48bb6ea9a361be01515ec15261bf1254a8c605db2ebf8166d323b43620e8f7c978cc79603be3ad537a191 SHA512 0c63e16449c40f15abdeed968383a218ed9876a92b2c15cbeb6554b20008d6d12996c0fd3bc1c502084791596b8535340596e95a11fe5d27576342740e76db6a
-EBUILD mupen64plus-audio-sdl-2.5.ebuild 1959 BLAKE2B bbc720d2b448e7c9894d8decc0c47e4695cc3c8d6f655f8fc664d8672e8972cb1277a696c5875b02a0d21b8af4c3460f7b3a26b4788c7ce3425402c547a93bf2 SHA512 4dcc0513f5f40de0d0a0603b3c391b827f78fc217ea255c8c4378c41dfe82c8f6efc5c7533fc18c9c54489a8639211f95804c6f1c747e73aeafca8c758ac56fb
+EBUILD mupen64plus-audio-sdl-2.5.9.ebuild 1932 BLAKE2B 1dc0373a06a4bb05899c7e4284ae005da891378071abde21e6d552d864214252bd46e3f658a1ac2a0a78ace13b6978b0b4b150b4e60d36edc8e340cd583a89ce SHA512 730072477d72b3e6d6442bf157189c2fb227af81b3117464a069ed44d9a9c3e5531e2b3844f34e853f6f849f906a0c18399f86d3d602aff5b8815b3a70ccf5f5
+EBUILD mupen64plus-audio-sdl-2.5.ebuild 1960 BLAKE2B d5fd7a40aaf734c016bb45567e92f0c0580a2055804b3c3aecb9ecc15a0d55e0197bf8a413207849b41f3cb6c80110548f34881a0db6878bd2f4c86b141536f4 SHA512 c82c81e249755ad16ed4c7442b383f74cf042f9918a1920e0524e677eb6195f38ec224b563f5ee8f419655efe0a8c1bde758590d293d36daa0b707aa70923697
MISC metadata.xml 345 BLAKE2B b5b03b304e1491135b6d30001afe6bd57e29873222bb41cbb4d9d47fd77be1581544139cf4800ad4f15afb4cbd0b9da167b2a6cb3242a2ce0e0689b7b88e6c1c SHA512 f6e02ffd8784ef686cea561d75bac4a5f231fa62e72a089380707663a738e3d10b1f134cce40cc8d60e36cf90ab9303971996b16797253f6509960873e787f2d
diff --git a/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.9.ebuild b/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.9.ebuild
new file mode 100644
index 000000000000..5b2611dce5b9
--- /dev/null
+++ b/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.9.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${PN}-src-${PV}
+inherit toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL audio plugin"
+HOMEPAGE="https://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libsamplerate oss speex"
+
+RDEPEND=">=games-emulation/mupen64plus-core-${PV}:0=
+ media-libs/libsdl2:0=[sound]
+ libsamplerate? ( media-libs/libsamplerate:0= )
+ speex? ( media-libs/speex:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+
+ NO_SPEEX=$(usex speex 0 1)
+ NO_SRC=$(usex libsamplerate 0 1)
+ NO_OSS=$(usex oss 0 1)
+ # not packaged (https://github.com/nemomobile/libaudioresource)
+ USE_AUDIORESOURCE=0
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ dodoc RELEASE
+}
diff --git a/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild b/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild
index 9ddb524fc2d5..09119f1b5193 100644
--- a/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild
+++ b/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild
@@ -7,7 +7,7 @@ MY_P=${PN}-src-${PV}
inherit eutils multilib toolchain-funcs
DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL audio plugin"
-HOMEPAGE="http://www.mupen64plus.org/"
+HOMEPAGE="https://www.mupen64plus.org/"
SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"