summaryrefslogtreecommitdiff
path: root/games-emulation/m64py
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/m64py')
-rw-r--r--games-emulation/m64py/Manifest2
-rw-r--r--games-emulation/m64py/m64py-0.2.5_p20231226.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/games-emulation/m64py/Manifest b/games-emulation/m64py/Manifest
index 119bf9783503..b48fcfe37fd8 100644
--- a/games-emulation/m64py/Manifest
+++ b/games-emulation/m64py/Manifest
@@ -1,4 +1,6 @@
AUX m64py-0.2.5_p20211222-setuptools-69.patch 432 BLAKE2B 1e6044678d148b7c31896127cbb2d1447790247efac157782016f2c611aa80a68ae2dda2a2c5258824593bc489c100ad783aa1773410637bcf07f541b43d7a25 SHA512 47b6683907721c5f93097dff361a02a20efd56bf500447eb31d5078d8699da5ec6069bf2b45bd5bb249f9cf74bf0a5d848f076b7fd4685dfab14c7840fcb4241
+DIST mupen64plus-ui-python-90093ce3b353ff0fbe3277eb5d75130debdf0fab.gh.tar.gz 14669607 BLAKE2B 98384d2fd8c0adda12500006e40aa50856cf74b71d8cd6b95a9717e864ebb85b76f8b3b719b84adca29a5269b8c5af447c144fb15f4e061ae44ff9d6cd097345 SHA512 75756367306a951110ed7b37aec875627d6e807e70d51518b771c4592c7e6bf7acc0e4e18531b33cabc2317c78b333e556f47e06227d8af0a767ca350c9685ee
DIST mupen64plus-ui-python-e24679436a93e8aae0aa664dc4b2dea40d8236c1.gh.tar.gz 14669412 BLAKE2B 08232599557503d606db9e44bdd6dbb30b3fa125bfd9b9bcc2cbc4b6ea71b567f5af4338d03e7580707db522249d9426ec4d64dc1e941a43076b2d21bc974b67 SHA512 2ba865041827a7f47d5151db6123abd62c964c024c14356aa5434619736b19ce150178d536cff1c84e93d0544823e173c67c0f08054c13e01f085912a9b8c2c6
EBUILD m64py-0.2.5_p20211222.ebuild 1574 BLAKE2B 713ad575a768a1eaf58f3955c60b186727eaa8bf2f6a5c69c0064dc141302098531b81011d645bbc4b95c20a47275bbb927958e1203d0e6dc6e743fa3bcdff45 SHA512 505075fcb1023252312c16cf748beea5fc7e54014f650c7649e1d32c708be589c5a94e9322bae6d9a382e3b141e23ed7b5f4e1f309c1943fb0e3bf0eebd193dd
+EBUILD m64py-0.2.5_p20231226.ebuild 1444 BLAKE2B 9152ef90c75da0c93c2721bd15a1673032e381e98adf0a6751fc25795fb96bdcecf5bd061947f54088370d585735b766405b9f8cb199dd5b7b795795e1721a68 SHA512 4a3b6e0ce084a0cc03fb8855379faf82b879acfe47a65d856aeae6be0e111871477b574edff14617378fa79445c1f66ae9e8488898fe923d5de867eaf13e72c3
MISC metadata.xml 529 BLAKE2B b801b519f763b135497d8bab8365efd40917d1ceb8a6a8e1d07f569b6afbdd6b481d959d8fab5735ae2ba524578b3302436ab2bfad02f605f778fa15352cd0f5 SHA512 147e334f1ec9c42f39ec8cb5387a4b28ff95d574dc2dc01e2fb9754f045a7d3850313bb1c000929961fe0922ed82c2c4eb5191bc5188aee2e27b06c3cff08f61
diff --git a/games-emulation/m64py/m64py-0.2.5_p20231226.ebuild b/games-emulation/m64py/m64py-0.2.5_p20231226.ebuild
new file mode 100644
index 000000000000..f1a34a615846
--- /dev/null
+++ b/games-emulation/m64py/m64py-0.2.5_p20231226.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 qmake-utils xdg-utils
+
+EGIT_COMMIT="90093ce3b353ff0fbe3277eb5d75130debdf0fab"
+MY_P=mupen64plus-ui-python-${EGIT_COMMIT}
+
+DESCRIPTION="A frontend for Mupen64Plus"
+HOMEPAGE="
+ https://m64py.sourceforge.net/
+ https://github.com/mupen64plus/mupen64plus-ui-python/
+"
+SRC_URI="
+ https://github.com/mupen64plus/mupen64plus-ui-python/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3 LGPL-3 public-domain GPL-2 BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="7z rar"
+
+RDEPEND="
+ dev-python/PyQt5[gui,opengl,widgets,${PYTHON_USEDEP}]
+ dev-python/PySDL2[${PYTHON_USEDEP}]
+ media-libs/libsdl2[joystick,video]
+ >=games-emulation/mupen64plus-core-2.5:0/2-sdl2
+ 7z? (
+ app-arch/p7zip
+ )
+ rar? (
+ || (
+ dev-python/rarfile[${PYTHON_USEDEP}]
+ app-arch/unrar
+ app-arch/rar
+ )
+ )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+
+python_prepare_all() {
+ # set the correct search path
+ cat >> src/m64py/platform.py <<-_EOF_ || die
+ SEARCH_DIRS = ["/usr/$(get_libdir)/mupen64plus"]
+ _EOF_
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x PATH=$(qt5_get_bindir):${PATH}
+ distutils-r1_python_compile
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}