summaryrefslogtreecommitdiff
path: root/games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild')
-rw-r--r--games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild b/games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild
index 6fcd97ea2826..6a69c356ddca 100644
--- a/games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild
+++ b/games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Gameboy emulator with multiple renderers"
HOMEPAGE="https://sourceforge.net/projects/gnuboy/"
@@ -39,6 +39,10 @@ src_prepare() {
}
src_configure() {
+ # LTO type mismatches (bug #858701)
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local econfargs=(
$(use_with X x)
$(use_with sdl)