summaryrefslogtreecommitdiff
path: root/games-emulation/dosbox-staging
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dosbox-staging')
-rw-r--r--games-emulation/dosbox-staging/Manifest2
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/games-emulation/dosbox-staging/Manifest b/games-emulation/dosbox-staging/Manifest
index ca17698457b1..436dc413368c 100644
--- a/games-emulation/dosbox-staging/Manifest
+++ b/games-emulation/dosbox-staging/Manifest
@@ -1,5 +1,7 @@
DIST dosbox-staging-0.76.0.tar.gz 1908605 BLAKE2B 71b3c3d6a6444e2442d54b1db365ea66c9ee3db703be876facb8425355d82d817c080e005cefd103714e15fc7d1c17d6329c28d67bf74c143d0428e4f58e5142 SHA512 8c0357bcec08cac2cd2b306edd8b51ad05e16a3c3efb1f4c77e1d942f285493cae8aab45f1633e9c168c0b4b45aa289cf3ffc72685dc004d83127cdb6c76ae9d
DIST dosbox-staging-0.77.0.tar.gz 2579927 BLAKE2B 2a8381451ec110ca5350afc70c45f158329bd273b381ff61856ab721a0b194c7d501402453e9a36b90663ee8f6697dce8f64b05adf56efa8df2fd68161e420b6 SHA512 37259fecc091f1e318c2385d6e6fdc3b4ad0905ce63a7db1fc812c924bf8c01640692aca4f08b87d06e6001e50f3f2f4bb63c3715aa9cdfeebd205ed345558a0
+DIST dosbox-staging-0.77.1.tar.gz 2622418 BLAKE2B c56020d263ceac199266a5c458c192441f836ea2e71e1564da175b7ae522286ca1b6a07062498ccea795bbf330beecb5ef99a0130637b1df26603315d48ea6ff SHA512 fe5d6150a88f5c276aee5672f98c15b5ffee702fe9934919d3e78068efd1a85f08a8f04352bc6a8fe850324e33f3227340c59242db6cbae0475b12a58b749cac
EBUILD dosbox-staging-0.76.0.ebuild 1431 BLAKE2B d6fefe9c171bd48de4246e239d95ebc78bbc02cf1aa138712cc3a2ed76fa9a5a5a181770e8d3f2173079770ef56b4adb83f8843d2fbfcfa6996c8806936912c6 SHA512 3fa322c2f91c97d0f86befc97c93d0e4dd4dcdba56055a97a8dd0fe85907e7319353cf85790dfc790fe811a9ba8990eaece8d86040255cf55f99ea8b502b5ea5
EBUILD dosbox-staging-0.77.0-r1.ebuild 1458 BLAKE2B 0e0f6a28fe7851bded45749a2322b9b9225335c14923ed4ce1aeeb915f0a5a2eb21daba8b7862d8fdffc267210354053c10b0e038a7c5e41beb0020490c05c7b SHA512 88e4b4aa99fd3c25475aca2e522a23300b9af2628c7f64b9a8832105a350d99f451d6634b5336b11fdee173374d34975f41f46df25840c09178fb3286bf1f4a5
+EBUILD dosbox-staging-0.77.1.ebuild 1458 BLAKE2B 0e0f6a28fe7851bded45749a2322b9b9225335c14923ed4ce1aeeb915f0a5a2eb21daba8b7862d8fdffc267210354053c10b0e038a7c5e41beb0020490c05c7b SHA512 88e4b4aa99fd3c25475aca2e522a23300b9af2628c7f64b9a8832105a350d99f451d6634b5336b11fdee173374d34975f41f46df25840c09178fb3286bf1f4a5
MISC metadata.xml 797 BLAKE2B 0ed46471b4346f54c7072632f46f3b430b4b7952dae71f4bbc1f87eeb818db285eace15573b3e236ea24baa23622479ab5150df0ad01a0f34d8204ea49b28c78 SHA512 c20d218c8b4eff1ac91c33f02adda6be7bdfd0301add882b612ea2d2513782e3ef160b3a84c99e22a3c2707d90ddcc5b0fb76558fdc0d64c6c2831bcd4a44a07
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
new file mode 100644
index 000000000000..5815a612b2b1
--- /dev/null
+++ b/games-emulation/dosbox-staging/dosbox-staging-0.77.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit meson xdg
+
+DESCRIPTION="Modernized DOSBox soft-fork"
+HOMEPAGE="https://dosbox-staging.github.io/"
+SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa debug dynrec +fluidsynth mt-32 network opengl"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ debug? ( sys-libs/ncurses:0= )
+ fluidsynth? (
+ media-sound/fluid-soundfont
+ media-sound/fluidsynth
+ )
+ mt-32? ( media-libs/munt-mt32emu )
+ network? ( media-libs/sdl2-net )
+ opengl? ( virtual/opengl )
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,opengl?,video,X]
+ media-libs/opusfile
+ sys-libs/zlib
+ !games-emulation/dosbox"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+DOCS=( AUTHORS README THANKS )
+
+src_prepare() {
+ default
+
+ # We do not have default.sf2, use actual name from fluid-soundfont
+ sed -e "s/default.sf2/FluidR3_GM.sf2/" \
+ -i src/midi/midi_fluidsynth.cpp || die
+
+ # Disable license and docs install (handled by ebuild)
+ sed -e "/licenses_dir\|doc_dir/d" -i meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use alsa use_alsa)
+ $(meson_use debug)
+ -Ddynamic_core=$(usex dynrec dynrec dyn-x86)
+ $(meson_use fluidsynth use_fluidsynth)
+ $(meson_use mt-32 use_mt32emu)
+ $(meson_use network use_sdl2_net)
+ $(meson_use opengl use_opengl)
+ )
+ meson_src_configure
+}