summaryrefslogtreecommitdiff
path: root/games-emulation/dolphin/dolphin-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dolphin/dolphin-9999.ebuild')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index b2fd4d445542..fd99d4066165 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -11,7 +11,7 @@ inherit cmake desktop xdg-utils pax-utils plocale
if [[ ${PV} == *9999 ]]
then
EGIT_REPO_URI="https://github.com/dolphin-emu/dolphin"
- EGIT_SUBMODULES=()
+ EGIT_SUBMODULES=( Externals/mGBA/mgba )
inherit git-r3
else
inherit vcs-snapshot
@@ -109,6 +109,9 @@ src_prepare() {
picojson
# No code to detect shared library.
zstd
+
+ # This is a stripped-down mGBA for integrated GBA support
+ mGBA
)
local s
for s in "${KEEP_SOURCES[@]}"; do