summaryrefslogtreecommitdiff
path: root/games-board/xmahjongg/xmahjongg-3.7-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/xmahjongg/xmahjongg-3.7-r2.ebuild')
-rw-r--r--games-board/xmahjongg/xmahjongg-3.7-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-board/xmahjongg/xmahjongg-3.7-r2.ebuild b/games-board/xmahjongg/xmahjongg-3.7-r2.ebuild
new file mode 100644
index 000000000000..c4ba67f96136
--- /dev/null
+++ b/games-board/xmahjongg/xmahjongg-3.7-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+DESCRIPTION="Friendly GUI version of xmahjongg"
+HOMEPAGE="https://www.lcdf.org/xmahjongg/"
+SRC_URI="https://www.lcdf.org/xmahjongg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-drop-register-keyword.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newicon share/tiles/small.gif ${PN}.gif
+ make_desktop_entry xmahjongg "Xmahjongg" /usr/share/pixmaps/${PN}.gif
+}