summaryrefslogtreecommitdiff
path: root/games-board/sirius/sirius-0.8.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/sirius/sirius-0.8.0-r1.ebuild')
-rw-r--r--games-board/sirius/sirius-0.8.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-board/sirius/sirius-0.8.0-r1.ebuild b/games-board/sirius/sirius-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..c04568e02b57
--- /dev/null
+++ b/games-board/sirius/sirius-0.8.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A program for playing the game of othello/reversi"
+HOMEPAGE="http://sirius.bitvis.nu/"
+SRC_URI="http://sirius.bitvis.nu/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ gnome-base/gconf:2
+ gnome-base/libgnomecanvas
+ gnome-base/libgnomeui
+ x11-libs/gtk+:2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format.patch
+ "${FILESDIR}"/${P}-fix-desktop-file.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}