summaryrefslogtreecommitdiff
path: root/games-board/sirius/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/sirius/files')
-rw-r--r--games-board/sirius/files/sirius-0.8.0-fix-build-system.patch65
-rw-r--r--games-board/sirius/files/sirius-0.8.0-fix-desktop-file.patch14
-rw-r--r--games-board/sirius/files/sirius-0.8.0-format.patch11
3 files changed, 0 insertions, 90 deletions
diff --git a/games-board/sirius/files/sirius-0.8.0-fix-build-system.patch b/games-board/sirius/files/sirius-0.8.0-fix-build-system.patch
deleted file mode 100644
index e799616a492a..000000000000
--- a/games-board/sirius/files/sirius-0.8.0-fix-build-system.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-Fix configure.ac
-* Remove setting CFLAGS
-* Look for sqrt() in libm (bug 592414)
-
---- a/configure.in
-+++ b/configure.in
-@@ -1,26 +1,23 @@
- AC_PREREQ(2.52)
-
--AC_INIT(sirius, 0.8.0)
--AC_CONFIG_SRCDIR(src/sirius.c)
--AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
-+AC_INIT([sirius], [0.8.0])
-+AC_CONFIG_SRCDIR([src/sirius.c])
-+AM_INIT_AUTOMAKE
-
--AM_CONFIG_HEADER(config.h)
--
--AM_MAINTAINER_MODE
-+AC_CONFIG_HEADERS([config.h])
-
- AC_PROG_INTLTOOL
-
--AC_ISC_POSIX
- AC_PROG_CC
--AC_STDC_HEADERS
--AM_PROG_LIBTOOL
--AC_PROG_LIBTOOL
-+LT_INIT
-
- pkg_modules="gtk+-2.0 >= 1.3.13 gconf-2.0 libgnomeui-2.0 libgnomecanvas-2.0 libgnomeui-2.0 gdk-pixbuf-2.0"
- PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
--AC_SUBST(PACKAGE_CFLAGS)
--AC_SUBST(PACKAGE_LIBS)
-
-+dnl Look for sqrt() in libm
-+AC_SEARCH_LIBS([sqrt], [m], [], [
-+ AC_MSG_ERROR([unable to find the sqrt() function])
-+])
-
- GETTEXT_PACKAGE=sirius
- AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE")
-@@ -29,22 +26,6 @@
- ALL_LINGUAS="sv fr de ru"
- AM_GLIB_GNU_GETTEXT
-
--CFLAGS="-g -O3"
--
--AC_SUBST(CFLAGS)
--AC_SUBST(CPPFLAGS)
--AC_SUBST(LDFLAGS)
--
--dnl Use -Wall if we have gcc.
--changequote(,)dnl
--if test "x$GCC" = "xyes"; then
-- case " $CFLAGS " in
-- *[\ \ ]-Wall[\ \ ]*) ;;
-- *) CFLAGS="$CFLAGS -Wall" ;;
-- esac
--fi
--changequote([,])dnl
--
- AC_OUTPUT([
- Makefile
- po/Makefile.in
diff --git a/games-board/sirius/files/sirius-0.8.0-fix-desktop-file.patch b/games-board/sirius/files/sirius-0.8.0-fix-desktop-file.patch
deleted file mode 100644
index dfa411d5152b..000000000000
--- a/games-board/sirius/files/sirius-0.8.0-fix-desktop-file.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Fix QA violations in desktop file
-
---- a/sirius.desktop.in
-+++ b/sirius.desktop.in
-@@ -3,7 +3,7 @@
- _Name=Sirius
- _Comment=Sirius, a othello playing program
- Exec=sirius
--Icon=sirius.png
-+Icon=sirius
- Terminal=false
- Type=Application
--Categories=GNOME;Application;Game;
-+Categories=GNOME;Game;
diff --git a/games-board/sirius/files/sirius-0.8.0-format.patch b/games-board/sirius/files/sirius-0.8.0-format.patch
deleted file mode 100644
index 4bed292434d3..000000000000
--- a/games-board/sirius/files/sirius-0.8.0-format.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/sirius.c
-+++ b/src/sirius.c
-@@ -180,7 +180,7 @@
-
- paus = 1;
-
-- box = gtk_message_dialog_new (GTK_WINDOW (window), GTK_DIALOG_MODAL, GTK_MESSAGE_INFO, GTK_BUTTONS_OK, message);
-+ box = gtk_message_dialog_new (GTK_WINDOW (window), GTK_DIALOG_MODAL, GTK_MESSAGE_INFO, GTK_BUTTONS_OK, "%s", message);
- gtk_dialog_run (GTK_DIALOG(box));
- gtk_widget_destroy(box);
-