summaryrefslogtreecommitdiff
path: root/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild')
-rw-r--r--games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild60
1 files changed, 34 insertions, 26 deletions
diff --git a/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild b/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild
index b028b2871b2d..5bf6199b8d6d 100644
--- a/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild
+++ b/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild
@@ -1,25 +1,32 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils gnome2-utils
+EAPI=7
-DESCRIPTION="A traditional game of Brunei"
+inherit gnome2-utils toolchain-funcs
+
+DESCRIPTION="Traditional game of Brunei"
HOMEPAGE="http://pasang-emas.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- extras? ( mirror://sourceforge/${PN}/pasang-emas-themes-1.0.tar.bz2
- mirror://sourceforge/${PN}/pet-marble.tar.bz2
- mirror://sourceforge/${PN}/pet-fragrance.tar.bz2 )"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ extras? (
+ mirror://sourceforge/${PN}/pasang-emas-themes-1.0.tar.bz2
+ mirror://sourceforge/${PN}/pet-marble.tar.bz2
+ mirror://sourceforge/${PN}/pet-fragrance.tar.bz2
+ )"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="extras nls"
+RESTRICT="test" # only used to validate .xml help files and fetches .dtd for it
-RDEPEND="app-text/gnome-doc-utils
- >=x11-libs/gtk+-2.18.2:2
- virtual/libintl"
-DEPEND="${RDEPEND}
+RDEPEND="
+ app-text/gnome-doc-utils
+ x11-libs/gtk+:2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
app-text/rarian
nls? ( sys-devel/gettext )"
@@ -29,31 +36,32 @@ PATCHES=(
src_prepare() {
default
- sed -i \
- -e '/Encoding/d' \
- -e '/Icon/s:\.png::' \
- data/pasang-emas.desktop.in || die
+
+ sed -i '/Encoding/d;/Icon/s:\.png::' data/pasang-emas.desktop.in || die
+
gnome2_omf_fix
}
src_configure() {
- econf \
- --localedir=/usr/share/locale \
- --with-omf-dir=/usr/share/omf \
- --with-help-dir=/usr/share/gnome/help \
+ local econfargs=(
$(use_enable nls)
+ --with-help-dir="${EPREFIX}"/usr/share/gnome/help
+ --with-omf-dir="${EPREFIX}"/usr/share/omf
+ )
+ econf "${econfargs[@]}"
+}
+
+src_compile(){
+ emake AR="$(tc-getAR)"
}
src_install() {
default
+
if use extras; then
insinto /usr/share/${PN}/themes
- doins -r \
- "${WORKDIR}"/marble \
- "${WORKDIR}"/pasang-emas-themes-1.0/{conteng,kaca} \
- "${WORKDIR}"/fragrance
+ doins -r "${WORKDIR}"/{fragrance,marble,pasang-emas-themes-1.0/{conteng,kaca}}
fi
- use nls || rm -rf "${D}"usr/share/locale
}
pkg_preinst() {