summaryrefslogtreecommitdiff
path: root/games-board/natch/natch-2.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/natch/natch-2.4-r1.ebuild')
-rw-r--r--games-board/natch/natch-2.4-r1.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/games-board/natch/natch-2.4-r1.ebuild b/games-board/natch/natch-2.4-r1.ebuild
index 8b263b424b33..0e81bbc485f3 100644
--- a/games-board/natch/natch-2.4-r1.ebuild
+++ b/games-board/natch/natch-2.4-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=7
+
+inherit autotools
MY_P="Natch-${PV}"
DESCRIPTION="A program to solve chess proof games"
@@ -14,15 +15,22 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="sys-libs/ncurses:0"
-RDEPEND=${DEPEND}
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${P}-format.patch
+ "${FILESDIR}"/${P}-tinfo.patch
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_install() {
newbin src/Natch natch
dodoc AUTHORS ChangeLog NEWS README THANKS example.txt