summaryrefslogtreecommitdiff
path: root/games-board/gnome-chess
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/gnome-chess')
-rw-r--r--games-board/gnome-chess/Manifest2
-rw-r--r--games-board/gnome-chess/gnome-chess-46.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/games-board/gnome-chess/Manifest b/games-board/gnome-chess/Manifest
index 5e02508b8cc2..80e13f386d59 100644
--- a/games-board/gnome-chess/Manifest
+++ b/games-board/gnome-chess/Manifest
@@ -1,3 +1,5 @@
DIST gnome-chess-43.2.tar.xz 743344 BLAKE2B 755d70ef964f6337acf852edc6fdbe69fbf3b566dfc36fa697d4c4ecdeeae5df5d1979e54e3304e89963fab01655979a55ac4f827bb1f1b506ab3cea8d147117 SHA512 e10439dd39e61436e3174e1d599d30d06955e65b696b9c37a0e9a8f1a41d19f71f33cca83ec9cc8fe2d8b516c2ec113f22bf3ddd1f1f465286cbe5bde8bcc0a2
+DIST gnome-chess-46.0.tar.xz 782212 BLAKE2B dec141cac14b59b02a3c4e0f10b09e450bf962ff5b688a7cfb31b274e1b92bd0c09a6afa3a32bb21a137114edb349ff3ac7aa88918481374fe2d4baeeca7cef2 SHA512 e605b9750fdc77a0d2b6973f127fb2cf5fadb15080add728c80a8be5ce02035ff6cadb0351751a0612f09632602fe532405d62c68828fd0ec4bf83b9bd11301a
EBUILD gnome-chess-43.2.ebuild 1115 BLAKE2B 220d16594a250968beb583437520d0a104cae4861d27bc3d16e320e25c4e78822461c6b3a75ae90f7348421de8d1e7653fa9f1654ca8ea6dada6ee37d0e42236 SHA512 a6ba40e494a762943fdb0b0a4efaf72c5fce33e7ce9cd3f63daeafd3ff2402db54bb598b7466c4dd42313f002988e7bf2f6896e980bdaa5f07bd8f33b9d6ff4d
+EBUILD gnome-chess-46.0.ebuild 1084 BLAKE2B 7fed7d1fea85e478a4a8d49767d25cd8d83c4333a99586ec91f467fd05b74ff8268f64e8d11ece6504bc54617c9fc111978f264abd9ce5bc416546033e5902cf SHA512 b133b4690f97899b7bdca63706a88f9343119d50b244a9e9b88ce619f6856636c92e0116021930782f38e2dbfd7f588e47332657b1742ebdc60663512bf90f4e
MISC metadata.xml 352 BLAKE2B 074f6148ce26c919d90dab35327d5cedff08035effba8bcb241bf8498d76f4272ec9eb319b0cc4d7127bdb866c48c85b6200426ce62cd124fa9a5a53d7ea7e3b SHA512 9843fd4b8762345e40d89e8ecefdf62b40060691330d241a72516668ee12df23e035be932086f7969ef6a29aa03b55b4b3acc455274cc60a8961046f44a9bad7
diff --git a/games-board/gnome-chess/gnome-chess-46.0.ebuild b/games-board/gnome-chess/gnome-chess-46.0.ebuild
new file mode 100644
index 000000000000..888da6547d44
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-46.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-chess"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ gui-libs/gtk:4
+ >=gui-libs/libadwaita-1.0.0:1
+ >=gnome-base/librsvg-2.46.0:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ gnome-base/librsvg:2[vala]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-util/itstool
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To be able to play against a computer you will need
+to install a chess engine package, for example games-board/gnuchess"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}