summaryrefslogtreecommitdiff
path: root/games-arcade/xbill/xbill-2.1-r6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/xbill/xbill-2.1-r6.ebuild')
-rw-r--r--games-arcade/xbill/xbill-2.1-r6.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/games-arcade/xbill/xbill-2.1-r6.ebuild b/games-arcade/xbill/xbill-2.1-r6.ebuild
index fdff9e03b315..edeebb7b82a1 100644
--- a/games-arcade/xbill/xbill-2.1-r6.ebuild
+++ b/games-arcade/xbill/xbill-2.1-r6.ebuild
@@ -5,21 +5,20 @@ EAPI=8
inherit autotools desktop
-DESCRIPTION="A game about an evil hacker called Bill!"
+DESCRIPTION="Game about an evil hacker called Bill!"
HOMEPAGE="http://www.xbill.org/"
-SRC_URI="http://www.xbill.org/download/${P}.tar.gz
+SRC_URI="
+ http://www.xbill.org/download/${P}.tar.gz
https://dashboard.snapcraft.io/site_media/appmedia/2018/04/xbill.png"
LICENSE="GPL-1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~x86"
-IUSE=""
RDEPEND="
acct-group/gamestat
media-fonts/font-misc-misc
- x11-libs/libXaw
-"
+ x11-libs/libXaw"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
@@ -30,19 +29,23 @@ PATCHES=(
src_prepare() {
default
- mv configure.in configure.ac || die
+
eautoreconf
}
src_configure() {
- econf \
- --disable-motif \
- --disable-gtk \
+ local econfargs=(
+ --disable-motif
+ --disable-gtk
--enable-athena
+ )
+
+ econf "${econfargs[@]}"
}
src_install() {
default
+
doicon "${DISTDIR}"/${PN}.png
make_desktop_entry ${PN} XBill ${PN}