summaryrefslogtreecommitdiff
path: root/games-arcade/solarwolf
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/solarwolf')
-rw-r--r--games-arcade/solarwolf/Manifest2
-rw-r--r--games-arcade/solarwolf/solarwolf-1.5-r1.ebuild (renamed from games-arcade/solarwolf/solarwolf-1.5.ebuild)26
2 files changed, 16 insertions, 12 deletions
diff --git a/games-arcade/solarwolf/Manifest b/games-arcade/solarwolf/Manifest
index 775e6031d775..d8bce2e450ac 100644
--- a/games-arcade/solarwolf/Manifest
+++ b/games-arcade/solarwolf/Manifest
@@ -1,3 +1,3 @@
DIST solarwolf-1.5.tar.gz 2045888 BLAKE2B 66498b1d9b202b45ff87ea9d4b1ab14dcb6e343e8b0761576cfbf1c84ee9575cbf665e4b94552eb764f5e4fbaa02739f62c9eb20217085a6d18483d3ca7eb587 SHA512 44d84976f7797e3b859f1e5e50f9f964e5c6d6d4437ad25cf04720035e8697cc0c86490fdbbf8d923320a5c15c6e3afd1fbcfb9f17e7e31ce6f7264004e991f2
-EBUILD solarwolf-1.5.ebuild 793 BLAKE2B 7a51105dc8edc6b1731b67ee790dc512f7122e43ecae9b016df21c7960b4166286bb4080a7d83c290d27f32509fdcd83e20b65f74041107b983c07c4f7536c65 SHA512 1a72a45f83a5aea1f226debb0e9f38d2d51e61180956c45b46e83897ff5951e0046ed350452bd999d196b9cf868102f538beb64bbf2497c38e30b6566682342b
+EBUILD solarwolf-1.5-r1.ebuild 798 BLAKE2B ba969bfbaacf80d6a40385f4e6f60e603b0389287a1f71f541a9a9f87f98d9674ea63d167e07ff1b13a14669a074d6b45076d9c6740f1bf87ba8bb9b98894c28 SHA512 6e250abdab04450254a5d29bdb6aa8962c3a9194ade5eab8669b95db6ab9a620c1388a8a7a757ccc2f2b58de601d885b028c67add97a44373f5e12a4ab416218
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-arcade/solarwolf/solarwolf-1.5.ebuild b/games-arcade/solarwolf/solarwolf-1.5-r1.ebuild
index b96deec76cec..dc3d846b8b7a 100644
--- a/games-arcade/solarwolf/solarwolf-1.5.ebuild
+++ b/games-arcade/solarwolf/solarwolf-1.5-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils games
+EAPI=6
+inherit eutils
-DESCRIPTION="action/arcade recreation of SolarFox"
+DESCRIPTION="Action/arcade recreation of SolarFox"
HOMEPAGE="http://www.pygame.org/shredwheat/solarwolf/"
SRC_URI="http://www.pygame.org/shredwheat/solarwolf/${P}.tar.gz"
@@ -13,20 +13,24 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~x86"
IUSE=""
-RDEPEND=">=dev-python/pygame-1.5.6
- media-libs/sdl-mixer[mod,vorbis]"
+RDEPEND="
+ >=dev-python/pygame-1.5.6
+ media-libs/sdl-mixer[mod,vorbis]
+"
+DEPEND=""
src_prepare() {
+ default
find . -name .xvpics -print0 | xargs -0 rm -fr
+ gunzip dist/${PN}.6.gz || die #619948
}
src_install() {
- insinto "$(games_get_libdir)"/${PN}
+ insinto /usr/share/${PN}
doins -r code data *py
- games_make_wrapper ${PN} "python2 ./solarwolf.py" "$(games_get_libdir)"/${PN}
+ make_wrapper ${PN} "python2 ./solarwolf.py" /usr/share/${PN}
doicon dist/${PN}.png
make_desktop_entry ${PN} SolarWolf
- dodoc readme.txt
- doman dist/${PN}.6.gz
- prepgamesdirs
+ einstalldocs
+ doman dist/${PN}.6
}