summaryrefslogtreecommitdiff
path: root/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/pengupop/pengupop-2.2.5-r1.ebuild')
-rw-r--r--games-arcade/pengupop/pengupop-2.2.5-r1.ebuild53
1 files changed, 14 insertions, 39 deletions
diff --git a/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild b/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
index 6938c534c5c9..c10d3f82d4a8 100644
--- a/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
+++ b/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
@@ -1,55 +1,30 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools desktop gnome2-utils
+EAPI=8
-DESCRIPTION="Networked multiplayer-only Puzzle Bubble clone"
+inherit desktop
+
+DESCRIPTION="Networked Puzzle Bubble clone"
HOMEPAGE="http://freshmeat.net/projects/pengupop"
SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="media-libs/libsdl[sound,video]
- sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
-
- eapply "${FILESDIR}"/${P}-underlink.patch
-
- sed -i \
- -e '/Icon/s/\.png//' \
- -e '/^Encoding/d' \
- -e '/Categories/s/Application;//' \
- pengupop.desktop || die
- sed -i \
- -e 's/-g -Wall -O2/-Wall/' \
- Makefile.am || die
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
- mv configure.in configure.ac || die
- eautoreconf
+src_compile() {
+ emake LIBS=-lm #497196
}
src_install() {
default
- domenu pengupop.desktop
- doicon -s 48 pengupop.png
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-pkg_postrm() {
- gnome2_icon_cache_update
+ doicon pengupop.png
+ make_desktop_entry ${PN} Pengupop
}