summaryrefslogtreecommitdiff
path: root/games-arcade/opentyrian/files/opentyrian-2.1.20130907-datapath.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/opentyrian/files/opentyrian-2.1.20130907-datapath.patch')
-rw-r--r--games-arcade/opentyrian/files/opentyrian-2.1.20130907-datapath.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/games-arcade/opentyrian/files/opentyrian-2.1.20130907-datapath.patch b/games-arcade/opentyrian/files/opentyrian-2.1.20130907-datapath.patch
new file mode 100644
index 000000000000..8ebf427d0797
--- /dev/null
+++ b/games-arcade/opentyrian/files/opentyrian-2.1.20130907-datapath.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -49,6 +49,10 @@
+ ALL_LDFLAGS += $(LDFLAGS)
+ LDLIBS += $(EXTRA_LDLIBS) $(SDL_LDLIBS)
+
++ifneq ($(DATA_PATH), )
++ CFLAGS += -DDATA_PATH=\"$(DATA_PATH)\"
++endif
++
+ # RULES ####################################################
+
+ .PHONY : all release clean
+--- a/src/file.c
++++ b/src/file.c
+@@ -34,7 +34,7 @@
+ #ifdef TARGET_MACOSX
+ tyrian_game_folder(),
+ #endif
+- "/usr/share/opentyrian/data"
++ DATA_PATH
+ };
+
+ static const char *dir = NULL;