summaryrefslogtreecommitdiff
path: root/games-arcade/openmortal/openmortal-0.7-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/openmortal/openmortal-0.7-r4.ebuild')
-rw-r--r--games-arcade/openmortal/openmortal-0.7-r4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-arcade/openmortal/openmortal-0.7-r4.ebuild b/games-arcade/openmortal/openmortal-0.7-r4.ebuild
new file mode 100644
index 000000000000..58706bdc410b
--- /dev/null
+++ b/games-arcade/openmortal/openmortal-0.7-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+DESCRIPTION="A spoof of the famous Mortal Kombat game"
+HOMEPAGE="http://openmortal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-libs/libsdl[joystick,video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ >=media-libs/freetype-2.4.0:2
+ dev-lang/perl
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}"-gcc41.patch
+ "${FILESDIR}/${P}"-freetype.patch
+ "${FILESDIR}/${P}"-freetype_pkgconfig.patch
+)
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newicon data/gfx/icon.png ${PN}.png
+ make_desktop_entry ${PN} OpenMortal
+}