summaryrefslogtreecommitdiff
path: root/games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild')
-rw-r--r--games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild26
1 files changed, 6 insertions, 20 deletions
diff --git a/games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild b/games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild
index b770ad759c89..a34d56ef3213 100644
--- a/games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild
+++ b/games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild
@@ -1,25 +1,23 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit desktop eutils gnome2-utils
+inherit desktop wrapper xdg
DESCRIPTION="Arcade 2d action game based around evacuating civilians from burning buildings"
HOMEPAGE="https://tangramgames.dk/games/mrrescue/"
SRC_URI="https://github.com/SimonLarsen/mrrescue/releases/download/v${PV}/${P}-love.zip
- https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+ mirror://gentoo/${PN}.png"
+S="${WORKDIR}/${P}-love"
LICENSE="CC-BY-SA-3.0 MIT ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
LVSLOT="0.8"
RDEPEND="games-engines/love:${LVSLOT}"
-DEPEND="app-arch/unzip"
-
-S="${WORKDIR}/${P}-love"
+BDEPEND="app-arch/unzip"
src_install() {
local dir=/usr/share/love/${PN}
@@ -33,15 +31,3 @@ src_install() {
make_wrapper ${PN} "love-${LVSLOT} ${PN}.love" "${dir}"
make_desktop_entry ${PN}
}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}