summaryrefslogtreecommitdiff
path: root/games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild')
-rw-r--r--games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild b/games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild
index 16ed5d364bad..6b5db838ab75 100644
--- a/games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild
+++ b/games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit desktop toolchain-funcs
DESCRIPTION="2D platform game"
@@ -29,10 +29,11 @@ PATCHES=(
"${FILESDIR}"/${P}-build.patch
"${FILESDIR}"/${P}-gcc44.patch
"${FILESDIR}"/${P}-underlink.patch
+ "${FILESDIR}"/${P}-gcc-11.patch
)
src_compile() {
- tc-export AR
+ tc-export AR CXX
emake -C JLib
emake -C src HC_BASE=/usr/share/${PN}/
}