summaryrefslogtreecommitdiff
path: root/games-arcade/epiar/epiar-0.5.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/epiar/epiar-0.5.1-r1.ebuild')
-rw-r--r--games-arcade/epiar/epiar-0.5.1-r1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/games-arcade/epiar/epiar-0.5.1-r1.ebuild b/games-arcade/epiar/epiar-0.5.1-r1.ebuild
index ba4c0b862a2c..994a9dc22a21 100644
--- a/games-arcade/epiar/epiar-0.5.1-r1.ebuild
+++ b/games-arcade/epiar/epiar-0.5.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
LUA_COMPAT=( lua5-1 )
-inherit autotools lua-single
+inherit autotools flag-o-matic lua-single
DESCRIPTION="Space adventure/combat game"
HOMEPAGE="https://epiar.net/"
@@ -41,6 +41,14 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # -DLUA_COMPAT_OPENLIB=1 is required to enable the
+ # deprecated (in 5.1) luaL_openlib API (#872803)
+ append-cppflags -DLUA_COMPAT_OPENLIB=1
+
+ default
+}
+
src_install() {
default