summaryrefslogtreecommitdiff
path: root/games-arcade/crack-attack/crack-attack-1.1.14-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/crack-attack/crack-attack-1.1.14-r2.ebuild')
-rw-r--r--games-arcade/crack-attack/crack-attack-1.1.14-r2.ebuild33
1 files changed, 21 insertions, 12 deletions
diff --git a/games-arcade/crack-attack/crack-attack-1.1.14-r2.ebuild b/games-arcade/crack-attack/crack-attack-1.1.14-r2.ebuild
index eded2a71ead8..24ca982cd260 100644
--- a/games-arcade/crack-attack/crack-attack-1.1.14-r2.ebuild
+++ b/games-arcade/crack-attack/crack-attack-1.1.14-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit desktop
+EAPI=7
+inherit autotools desktop
DESCRIPTION="Addictive OpenGL-based block game"
HOMEPAGE="http://www.nongnu.org/crack-attack/"
@@ -15,28 +15,37 @@ IUSE="gtk sdl"
RDEPEND="
media-libs/freeglut
- sdl? ( media-libs/libsdl
- media-libs/sdl-mixer )
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ )
gtk? ( >=x11-libs/gtk+-2.6:2 )
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${P}-glut.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-avoid_bashisms.patch
+)
+
src_prepare() {
default
- eapply \
- "${FILESDIR}"/${P}-glut.patch \
- "${FILESDIR}"/${P}-gcc43.patch
+ eautoreconf
sed -i 's/-lXmu//' src/gtk-gui/Makefile.in src/Makefile.in || die
touch -r . * */*
}
src_configure() {
- econf \
- --disable-binreloc \
- $(use_enable sdl sound) \
+ local myeconfargs=(
+ --disable-binreloc
+ $(use_enable sdl sound)
$(use_enable gtk)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {