summaryrefslogtreecommitdiff
path: root/games-arcade/burgerspace/burgerspace-1.9.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/burgerspace/burgerspace-1.9.3-r1.ebuild')
-rw-r--r--games-arcade/burgerspace/burgerspace-1.9.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-arcade/burgerspace/burgerspace-1.9.3-r1.ebuild b/games-arcade/burgerspace/burgerspace-1.9.3-r1.ebuild
new file mode 100644
index 000000000000..20885e388a68
--- /dev/null
+++ b/games-arcade/burgerspace/burgerspace-1.9.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="Clone of the 1982 BurgerTime video game by Data East"
+HOMEPAGE="http://perso.b2b2c.ca/~sarrazip/dev/burgerspace.html"
+SRC_URI="http://perso.b2b2c.ca/~sarrazip/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="network"
+RESTRICT="test" # doesn't really test anything
+
+RDEPEND=">=dev-games/flatzebra-0.1.7
+ media-libs/libsdl[joystick]
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.9.3-autotools.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with network)
+}