summaryrefslogtreecommitdiff
path: root/games-arcade/aop/aop-0.6-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/aop/aop-0.6-r2.ebuild')
-rw-r--r--games-arcade/aop/aop-0.6-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-arcade/aop/aop-0.6-r2.ebuild b/games-arcade/aop/aop-0.6-r2.ebuild
new file mode 100644
index 000000000000..d0849e3b9401
--- /dev/null
+++ b/games-arcade/aop/aop-0.6-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Ambassador of Pain is a curses based game with only 64 lines of code"
+HOMEPAGE="http://raffi.at/view/code/aop"
+SRC_URI="http://www.raffi.at/code/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-as-needed.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s#/usr/local/share#/usr/share/${PN}#" \
+ aop.c || die
+}
+
+src_install() {
+ dobin aop
+
+ insinto "/usr/share/${PN}"
+ doins aop-level-*.txt
+
+ einstalldocs
+}