summaryrefslogtreecommitdiff
path: root/games-arcade/alienwave/alienwave-0.4.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/alienwave/alienwave-0.4.0-r2.ebuild')
-rw-r--r--games-arcade/alienwave/alienwave-0.4.0-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-arcade/alienwave/alienwave-0.4.0-r2.ebuild b/games-arcade/alienwave/alienwave-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..55f4f0182698
--- /dev/null
+++ b/games-arcade/alienwave/alienwave-0.4.0-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="An ncurses-based Xenon clone"
+HOMEPAGE="http://www.alessandropira.org/alienwave/aw.html"
+SRC_URI="http://www.alessandropira.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ emake LIB="$($(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
+src_install() {
+ dobin alienwave
+ dodoc TO_DO README STORY
+}