summaryrefslogtreecommitdiff
path: root/games-arcade/alienwave/alienwave-0.4.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/alienwave/alienwave-0.4.0-r1.ebuild')
-rw-r--r--games-arcade/alienwave/alienwave-0.4.0-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/games-arcade/alienwave/alienwave-0.4.0-r1.ebuild b/games-arcade/alienwave/alienwave-0.4.0-r1.ebuild
index eda16474a7f5..7667f63fda5b 100644
--- a/games-arcade/alienwave/alienwave-0.4.0-r1.ebuild
+++ b/games-arcade/alienwave/alienwave-0.4.0-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="An ncurses-based Xenon clone"
HOMEPAGE="http://www.alessandropira.org/alienwave/aw.html"
@@ -14,11 +16,16 @@ IUSE=""
DEPEND="sys-libs/ncurses:0"
RDEPEND=${DEPEND}
+BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${PN}"
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+src_compile() {
+ emake LIB="$($(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
src_install() {
dobin alienwave
dodoc TO_DO README STORY