summaryrefslogtreecommitdiff
path: root/games-action/minecraft-launcher/minecraft-launcher-928-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/minecraft-launcher/minecraft-launcher-928-r4.ebuild')
-rw-r--r--games-action/minecraft-launcher/minecraft-launcher-928-r4.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/games-action/minecraft-launcher/minecraft-launcher-928-r4.ebuild b/games-action/minecraft-launcher/minecraft-launcher-928-r4.ebuild
new file mode 100644
index 000000000000..17acf52bc03c
--- /dev/null
+++ b/games-action/minecraft-launcher/minecraft-launcher-928-r4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="An open-world game whose gameplay revolves around breaking and placing blocks"
+HOMEPAGE="https://www.minecraft.net/"
+SRC_URI="https://launcher.mojang.com/download/linux/x86_64/minecraft-launcher_${PV}.tar.gz -> ${P}.tar.gz
+ https://launcher.mojang.com/download/minecraft-launcher.svg"
+
+KEYWORDS="-* ~amd64"
+LICENSE="Mojang"
+SLOT="0"
+
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.24.32-r1[X(+)]
+ app-crypt/libsecret
+ dev-libs/nss
+ dev-libs/libbsd
+ || ( dev-libs/libffi-compat:7 dev-libs/libffi:0/7 )
+ dev-libs/libpcre
+ media-libs/alsa-lib
+ media-libs/openal
+ net-libs/gnutls[idn]
+ net-misc/curl[adns]
+ net-print/cups
+ sys-apps/dbus
+ virtual/jre:1.8
+ virtual/opengl
+ x11-apps/xrandr
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/xcb-util
+"
+
+S="${WORKDIR}/${PN}"
+
+QA_PREBUILT="
+ /usr/bin/minecraft-launcher
+"
+
+src_install() {
+ dobin minecraft-launcher
+
+ doicon -s scalable "${DISTDIR}/${PN}.svg"
+ make_desktop_entry ${PN} "Minecraft" ${PN} Game
+}