summaryrefslogtreecommitdiff
path: root/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20210623.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20210623.ebuild')
-rw-r--r--games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20210623.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20210623.ebuild b/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20210623.ebuild
index b941cf320c02..52185ad3b734 100644
--- a/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20210623.ebuild
+++ b/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20210623.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2017-2021 Gentoo Authors
+# Copyright 2017-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
-inherit desktop python-any-r1 scons-utils toolchain-funcs xdg
+inherit desktop flag-o-matic python-any-r1 scons-utils toolchain-funcs xdg
if [[ "${PV}" = 9999 ]]; then
inherit git-r3
@@ -215,6 +215,7 @@ dxx_scons() {
src_compile() {
tc-export CXX PKG_CONFIG
+ replace-flags -O3 -O2 #831896
dxx_scons register_install_target=0 build
}