summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin41332 -> 41172 bytes
-rw-r--r--eclass/cargo.eclass6
-rw-r--r--eclass/java-vm-2.eclass4
-rw-r--r--eclass/makeedit.eclass36
-rw-r--r--eclass/qt5-build.eclass4
5 files changed, 8 insertions, 42 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index b91f22045382..384c0c35bf5a 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/cargo.eclass b/eclass/cargo.eclass
index 4bb5954ca31c..799b0618bd25 100644
--- a/eclass/cargo.eclass
+++ b/eclass/cargo.eclass
@@ -16,6 +16,8 @@ case ${EAPI} in
*) die "EAPI=${EAPI:-0} is not supported" ;;
esac
+inherit multiprocessing
+
EXPORT_FUNCTIONS src_unpack src_compile src_install
IUSE="${IUSE} debug"
@@ -117,7 +119,7 @@ cargo_src_compile() {
export CARGO_HOME="${ECARGO_HOME}"
- cargo build -v $(usex debug "" --release) \
+ cargo build -v -j $(makeopts_jobs) $(usex debug "" --release) \
|| die "cargo build failed"
}
@@ -127,7 +129,7 @@ cargo_src_compile() {
cargo_src_install() {
debug-print-function ${FUNCNAME} "$@"
- cargo install --root="${D}/usr" $(usex debug --debug "") \
+ cargo install -j $(makeopts_jobs) --root="${D}/usr" $(usex debug --debug "") \
|| die "cargo install failed"
rm -f "${D}/usr/.crates.toml"
diff --git a/eclass/java-vm-2.eclass b/eclass/java-vm-2.eclass
index 4e053deb0ea9..9deef1c8eedf 100644
--- a/eclass/java-vm-2.eclass
+++ b/eclass/java-vm-2.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: java-vm-2.eclass
@@ -20,7 +20,7 @@ EXPORT_FUNCTIONS pkg_setup pkg_postinst pkg_prerm pkg_postrm
RDEPEND="
>=dev-java/java-config-2.2.0-r3
- >=app-eselect/eselect-java-0.2.0"
+ >=app-eselect/eselect-java-0.4.0"
DEPEND="${RDEPEND}"
export WANT_JAVA_CONFIG=2
diff --git a/eclass/makeedit.eclass b/eclass/makeedit.eclass
deleted file mode 100644
index fb40cf781912..000000000000
--- a/eclass/makeedit.eclass
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# @ECLASS: makeedit.eclass
-# @AUTHOR:
-# Spider
-# @BLURB: An eclass to replace some flags in makefiles
-# @DESCRIPTION:
-#
-# @CODE
-# To use this eclass, do 2 things:
-# 1. append-flags "$MAKEEDIT_FLAGS". If you filter-flags, make sure to do
-# the append-flags afterward, otherwise you'll lose them.
-# 2. after running configure or econf, call edit_makefiles to remove
-# extraneous CFLAGS from your Makefiles.
-# @CODE
-#
-# This combination should reduce the RAM requirements of your build, and maybe
-# even speed it up a bit.
-
-
-MAKEEDIT_FLAGS="-Wno-return-type -w"
-
-# @FUNCTION: edit_makefiles
-# @DESCRIPTION:
-# Removes some flags in makefiles
-edit_makefiles() {
- # We already add "-Wno-return-type -w" to compiler flags, so
- # no need to replace "-Wall" and "-Wreturn-type" with them.
- einfo "Parsing Makefiles ..."
- find . \( -iname makefile -o -name \*.mk -o -name GNUmakefile \) -print0 | \
- xargs -0 sed -i \
- -e 's:-Wall::g' \
- -e 's:-Wreturn-type::g' \
- -e 's:-pedantic::g'
-}
diff --git a/eclass/qt5-build.eclass b/eclass/qt5-build.eclass
index b664edb611bd..b381c28495cb 100644
--- a/eclass/qt5-build.eclass
+++ b/eclass/qt5-build.eclass
@@ -170,7 +170,7 @@ qt5-build_src_unpack() {
fi
case ${QT5_BUILD_TYPE} in
- live) git-r3_src_unpack ;;
+ live) git-r3_src_unpack ;&
release) default ;;
esac
}
@@ -843,7 +843,7 @@ qt5_install_module_config() {
)
fi
- # install also the original qconfig.pri
+ # install the original {qconfig,qmodule}.pri from qtcore
[[ ${PN} == qtcore && ${QT5_MINOR_VERSION} -ge 9 ]] && (
insinto "${QT5_ARCHDATADIR#${EPREFIX}}"/mkspecs/gentoo
newins "${D}${QT5_ARCHDATADIR}"/mkspecs/qconfig.pri qconfig-qtcore.pri