summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin35831 -> 35827 bytes
-rw-r--r--eclass/distutils-r1.eclass2
-rw-r--r--eclass/java-utils-2.eclass2
-rw-r--r--eclass/lua-single.eclass22
-rw-r--r--eclass/lua-utils.eclass5
-rw-r--r--eclass/lua.eclass12
-rw-r--r--eclass/python-utils-r1.eclass16
7 files changed, 33 insertions, 26 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index 1096a671790a..99f348ff53e0 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 344aa46b2f94..3207ed6f4b8e 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -129,7 +129,7 @@ _distutils_set_globals() {
rdep+=" ${setuptools_dep}"
;;
pyproject.toml)
- bdep+=' >=dev-python/pyproject2setuppy-15[${PYTHON_USEDEP}]'
+ bdep+=' >=dev-python/pyproject2setuppy-18[${PYTHON_USEDEP}]'
;;
*)
die "Invalid DISTUTILS_USE_SETUPTOOLS=${DISTUTILS_USE_SETUPTOOLS}"
diff --git a/eclass/java-utils-2.eclass b/eclass/java-utils-2.eclass
index ed4951ac97b7..0e2ed2902842 100644
--- a/eclass/java-utils-2.eclass
+++ b/eclass/java-utils-2.eclass
@@ -373,7 +373,7 @@ java-pkg_dojar() {
insinto "${JAVA_PKG_JARDEST}"
doins "${jar}"
) || die "failed to install ${jar}"
- java-pkg_append_ JAVA_PKG_CLASSPATH "${EPREFIX}/${JAVA_PKG_JARDEST}/${jar_basename}"
+ java-pkg_append_ JAVA_PKG_CLASSPATH "${EPREFIX}${JAVA_PKG_JARDEST}/${jar_basename}"
debug-print "installed ${jar} to ${ED}${JAVA_PKG_JARDEST}"
# make a symlink to the original jar if it's symlink
else
diff --git a/eclass/lua-single.eclass b/eclass/lua-single.eclass
index f55c3f809484..ba7973d82c44 100644
--- a/eclass/lua-single.eclass
+++ b/eclass/lua-single.eclass
@@ -36,7 +36,7 @@
# @CODE
# EAPI=8
#
-# LUA_COMPAT=( lua5-{1..3} )
+# LUA_COMPAT=( lua5-{3..4} )
#
# inherit lua-single
#
@@ -90,7 +90,7 @@ EXPORT_FUNCTIONS pkg_setup
#
# Example:
# @CODE
-# LUA_COMPAT=( lua5-1 lua5-2 lua5-3 )
+# LUA_COMPAT=( lua5-1 lua5-3 lua5-4 )
# @CODE
#
# Please note that you can also use bash brace expansion if you like:
@@ -115,7 +115,7 @@ EXPORT_FUNCTIONS pkg_setup
#
# Example:
# @CODE
-# LUA_COMPAT_OVERRIDE='lua5-2' emerge -1v dev-lua/foo
+# LUA_COMPAT_OVERRIDE='luajit' emerge -1v dev-lua/foo
# @CODE
# @ECLASS-VARIABLE: LUA_REQ_USE
@@ -154,7 +154,7 @@ EXPORT_FUNCTIONS pkg_setup
# Example value:
# @CODE
# lua_targets_lua5-1? ( dev-lang/lua:5.1 )
-# lua_targets_lua5-2? ( dev-lang/lua:5.2 )
+# lua_targets_lua5-3? ( dev-lang/lua:5.2 )
# @CODE
# @ECLASS-VARIABLE: LUA_REQUIRED_USE
@@ -173,7 +173,7 @@ EXPORT_FUNCTIONS pkg_setup
#
# Example value:
# @CODE
-# || ( lua_targets_lua5-1 lua_targets_lua5-2 )
+# || ( lua_targets_lua5-1 lua_targets_lua5-3 )
# @CODE
# @ECLASS-VARIABLE: LUA_SINGLE_USEDEP
@@ -210,7 +210,7 @@ EXPORT_FUNCTIONS pkg_setup
#
# Example value:
# @CODE
-# lua_targets_lua5-1(-)?,lua_targets_lua5-2(-)?
+# lua_targets_lua5-1(-)?,lua_targets_lua5-3(-)?
# @CODE
# @FUNCTION: _lua_single_set_globals
@@ -376,15 +376,15 @@ _lua_verify_patterns() {
# @CODE
# LUA_COMPAT=( lua5-{1..3} )
# RDEPEND="$(lua_gen_cond_dep \
-# 'dev-lua/backported_core_module[${LUA_USEDEP}]' lua5-1 lua5-2 )"
+# 'dev-lua/backported_core_module[${LUA_USEDEP}]' lua5-1 lua5-3 )"
# @CODE
#
# It will cause the variable to look like:
# @CODE
# RDEPEND="lua_single_target_lua5-1? (
# dev-lua/backported_core_module[lua_targets_lua5-1(-)?,...] )
-# lua_single_target_lua5-2? (
-# dev-lua/backported_core_module[lua_targets_lua5-2(-)?,...] )"
+# lua_single_target_lua5-3? (
+# dev-lua/backported_core_module[lua_targets_lua5-3(-)?,...] )"
# @CODE
lua_gen_cond_dep() {
debug-print-function ${FUNCNAME} "${@}"
@@ -436,13 +436,13 @@ lua_gen_cond_dep() {
# Example:
# @CODE
# LUA_COMPAT=( lua5-{1..3} )
-# RDEPEND="foo? ( $(lua_gen_impl_dep 'deprecated(+)' lua5-3 ) )"
+# RDEPEND="foo? ( $(lua_gen_impl_dep 'deprecated(+)' lua5-4 ) )"
# @CODE
#
# It will cause the variable to look like:
# @CODE
# RDEPEND="foo? (
-# lua_single_target_lua5-3? ( dev-lang/lua:5.3[deprecated(+)] )
+# lua_single_target_lua5-4? ( dev-lang/lua:5.3[deprecated(+)] )
# )"
# @CODE
lua_gen_impl_dep() {
diff --git a/eclass/lua-utils.eclass b/eclass/lua-utils.eclass
index 12067928002b..954f776cda2e 100644
--- a/eclass/lua-utils.eclass
+++ b/eclass/lua-utils.eclass
@@ -34,7 +34,6 @@ inherit toolchain-funcs
_LUA_ALL_IMPLS=(
luajit
lua5-1
- lua5-2
lua5-3
lua5-4
)
@@ -44,7 +43,9 @@ readonly _LUA_ALL_IMPLS
# @INTERNAL
# @DESCRIPTION:
# All historical Lua implementations that are no longer supported.
-_LUA_HISTORICAL_IMPLS=()
+_LUA_HISTORICAL_IMPLS=(
+ lua5-2
+)
readonly _LUA_HISTORICAL_IMPLS
# @FUNCTION: _lua_set_impls
diff --git a/eclass/lua.eclass b/eclass/lua.eclass
index e9a5c1175608..b6c309a3e55f 100644
--- a/eclass/lua.eclass
+++ b/eclass/lua.eclass
@@ -29,7 +29,7 @@
# @CODE
# EAPI=8
#
-# LUA_COMPAT=( lua5-{1..3} )
+# LUA_COMPAT=( lua5-{3..4} )
#
# inherit lua
#
@@ -76,7 +76,7 @@ fi
#
# Example:
# @CODE
-# LUA_COMPAT=( lua5-1 lua5-2 lua5-3 )
+# LUA_COMPAT=( lua5-1 lua5-3 lua5-4 )
# @CODE
#
# Please note that you can also use bash brace expansion if you like:
@@ -101,7 +101,7 @@ fi
#
# Example:
# @CODE
-# LUA_COMPAT_OVERRIDE='lua5-2' emerge -1v dev-lua/foo
+# LUA_COMPAT_OVERRIDE='luajit' emerge -1v dev-lua/foo
# @CODE
# @ECLASS-VARIABLE: LUA_REQ_USE
@@ -157,7 +157,7 @@ fi
# Example value:
# @CODE
# lua_targets_lua5-1? ( dev-lang/lua:5.1 )
-# lua_targets_lua5-2? ( dev-lang/lua:5.2 )
+# lua_targets_lua5-3? ( dev-lang/lua:5.2 )
# @CODE
# @ECLASS-VARIABLE: LUA_REQUIRED_USE
@@ -176,7 +176,7 @@ fi
#
# Example value:
# @CODE
-# || ( lua_targets_lua5-1 lua_targets_lua5-2 )
+# || ( lua_targets_lua5-1 lua_targets_lua5-3 )
# @CODE
# @ECLASS-VARIABLE: LUA_USEDEP
@@ -193,7 +193,7 @@ fi
#
# Example value:
# @CODE
-# lua_targets_lua5-1(-)?,lua_targets_lua5-2(-)?
+# lua_targets_lua5-1(-)?,lua_targets_lua5-3(-)?
# @CODE
if [[ ! ${_LUA_R0} ]]; then
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index b104b6694ac3..a2b5b6d5d41a 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -35,7 +35,7 @@ fi
if [[ ! ${_PYTHON_UTILS_R1} ]]; then
[[ ${EAPI} == [67] ]] && inherit eapi8-dosym
-inherit toolchain-funcs
+inherit multiprocessing toolchain-funcs
# @ECLASS-VARIABLE: _PYTHON_ALL_IMPLS
# @INTERNAL
@@ -590,6 +590,9 @@ python_optimize() {
debug-print "${FUNCNAME}: using sys.path: ${*/%/;}"
fi
+ local jobs=$(makeopts_jobs "${MAKEOPTS}" INF)
+ [[ ${jobs} == INF ]] && jobs=$(get_nproc)
+
local d
for d; do
# make sure to get a nice path without //
@@ -601,11 +604,14 @@ python_optimize() {
"${PYTHON}" -m compileall -q -f -d "${instpath}" "${d}"
"${PYTHON}" -OO -m compileall -q -f -d "${instpath}" "${d}"
;;
- python*|pypy3)
+ python3.[5678]|pypy3)
# both levels of optimization are separate since 3.5
- "${PYTHON}" -m compileall -q -f -d "${instpath}" "${d}"
- "${PYTHON}" -O -m compileall -q -f -d "${instpath}" "${d}"
- "${PYTHON}" -OO -m compileall -q -f -d "${instpath}" "${d}"
+ "${PYTHON}" -m compileall -j "${jobs}" -q -f -d "${instpath}" "${d}"
+ "${PYTHON}" -O -m compileall -j "${jobs}" -q -f -d "${instpath}" "${d}"
+ "${PYTHON}" -OO -m compileall -j "${jobs}" -q -f -d "${instpath}" "${d}"
+ ;;
+ python*)
+ "${PYTHON}" -m compileall -j "${jobs}" -o 0 -o 1 -o 2 --hardlink-dupes -q -f -d "${instpath}" "${d}"
;;
*)
"${PYTHON}" -m compileall -q -f -d "${instpath}" "${d}"