summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin38928 -> 38933 bytes
-rw-r--r--eclass/kernel-install.eclass8
-rw-r--r--eclass/toolchain.eclass17
3 files changed, 6 insertions, 19 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index 1f4b907a79d3..784c68f37c3c 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/kernel-install.eclass b/eclass/kernel-install.eclass
index 5a5b833cdd7b..5a98446b12ee 100644
--- a/eclass/kernel-install.eclass
+++ b/eclass/kernel-install.eclass
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: kernel-install.eclass
@@ -63,14 +63,14 @@ RESTRICT+="
_IDEPEND_BASE="
!initramfs? (
|| (
- >=sys-kernel/installkernel-gentoo-8
+ >=sys-kernel/installkernel-8
>=sys-kernel/installkernel-systemd-2-r5
)
)
initramfs? (
>=sys-kernel/dracut-059-r4
|| (
- >=sys-kernel/installkernel-gentoo-8[dracut(-)]
+ >=sys-kernel/installkernel-8[dracut(-)]
>=sys-kernel/installkernel-systemd-2-r5
)
)
@@ -200,8 +200,8 @@ if [[ ${KERNEL_IUSE_GENERIC_UKI} ]]; then
IDEPEND="
generic-uki? (
|| (
+ >=sys-kernel/installkernel-8[-dracut(-),-ukify(-),uki(-)]
>=sys-kernel/installkernel-systemd-3
- >=sys-kernel/installkernel-gentoo-8[-dracut(-),-ukify(-)]
)
)
!generic-uki? (
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 3601737979d8..b1f4ea9caf68 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -231,7 +231,7 @@ tc_has_feature() {
}
if [[ ${PN} != kgcc64 && ${PN} != gcc-* ]] ; then
- IUSE+=" debug +cxx +nptl" TC_FEATURES+=( nptl )
+ IUSE+=" debug +cxx"
IUSE+=" +fortran" TC_FEATURES+=( fortran )
IUSE+=" doc hardened multilib objc"
IUSE+=" pgo"
@@ -253,8 +253,7 @@ if [[ ${PN} != kgcc64 && ${PN} != gcc-* ]] ; then
IUSE+=" ada"
IUSE+=" vtv"
IUSE+=" jit"
- tc_version_is_between 5.0 9 && IUSE+=" mpx"
- IUSE+=" +pie +ssp +pch"
+ IUSE+=" +pie +ssp pch"
IUSE+=" systemtap" TC_FEATURES+=( systemtap )
@@ -1239,14 +1238,6 @@ toolchain_src_configure() {
confgcc+=( $(use_enable cet) )
fi
- if in_iuse cilk ; then
- confgcc+=( $(use_enable cilk libcilkrts) )
- fi
-
- if in_iuse mpx ; then
- confgcc+=( $(use_enable mpx libmpx) )
- fi
-
if in_iuse systemtap ; then
confgcc+=( $(use_enable systemtap) )
fi
@@ -2002,8 +1993,6 @@ toolchain_src_install() {
# libgfortran.la: gfortran itself handles linkage correctly in the
# dynamic & static case (libgfortran.spec). bug #573302
# libgfortranbegin.la: Same as above, and it's an internal lib.
- # libmpx.la: gcc itself handles linkage correctly (libmpx.spec).
- # libmpxwrappers.la: See above.
# libitm.la: gcc itself handles linkage correctly (libitm.spec).
# libvtv.la: gcc itself handles linkage correctly.
# lib*san.la: Sanitizer linkage is handled internally by gcc, and they
@@ -2020,8 +2009,6 @@ toolchain_src_install() {
-name 'libgomp-plugin-*.la' -o \
-name libgfortran.la -o \
-name libgfortranbegin.la -o \
- -name libmpx.la -o \
- -name libmpxwrappers.la -o \
-name libitm.la -o \
-name libvtv.la -o \
-name 'lib*san.la' \