summaryrefslogtreecommitdiff
path: root/eclass/toolchain.eclass
diff options
context:
space:
mode:
Diffstat (limited to 'eclass/toolchain.eclass')
-rw-r--r--eclass/toolchain.eclass9
1 files changed, 9 insertions, 0 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 93d4792af4d6..6d76823fb549 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1139,6 +1139,15 @@ toolchain_setup_ada() {
! tc-is-cross-compiler && _toolchain_make_gnat_wrappers
export CC="$(tc-getCC) -specs=${T}/ada.spec"
+
+ if ver_test ${PV} -lt 13 && [[ ${CTARGET} == hppa* ]] ; then
+ # For HPPA, the ada-bootstrap binaries seem to default
+ # to -fstack-protector still (maybe because of cross-building)
+ # so we need to override it for <13 (which ignores -fstack-protector)
+ # as SSP doesn't exist there. The GNAT configure test gets confused
+ # by GCC warning about this otherwise.
+ CC+=" -fno-stack-protector"
+ fi
}
# @FUNCTION: toolchain_setup_d