summaryrefslogtreecommitdiff
path: root/eclass/ecm.eclass
diff options
context:
space:
mode:
Diffstat (limited to 'eclass/ecm.eclass')
-rw-r--r--eclass/ecm.eclass8
1 files changed, 3 insertions, 5 deletions
diff --git a/eclass/ecm.eclass b/eclass/ecm.eclass
index 3c102d669caf..c633fe39d98c 100644
--- a/eclass/ecm.eclass
+++ b/eclass/ecm.eclass
@@ -129,8 +129,8 @@ fi
# "forceoptional-recursive".
# Default value is "false", except for CATEGORY=kde-frameworks where it is
# set to "true". If set to "false", do nothing.
-# For any other value, add "test" to IUSE and DEPEND on dev-qt/qtbase:6[test]
-# (for KF5: dev-qt/qttest:5). If set to "optional", build with
+# For any other value, add "test" to IUSE (and for KF5 DEPEND on
+# dev-qt/qttest:5). If set to "optional", build with
# -DCMAKE_DISABLE_FIND_PACKAGE_Qt${_KFSLOT}Test=ON when USE=!test. If set
# to "forceoptional", punt Qt${_KFSLOT}Test dependency and ignore "autotests",
# "test", "tests" subdirs from top-level CMakeLists.txt when USE=!test.
@@ -260,9 +260,7 @@ esac
case ${ECM_TEST} in
true|optional|forceoptional|forceoptional-recursive)
IUSE+=" test"
- if [[ ${_KFSLOT} == 6 ]]; then
- DEPEND+=" test? ( dev-qt/qtbase:${_KFSLOT}[test] )"
- else
+ if [[ ${_KFSLOT} == 5 ]]; then
DEPEND+=" test? ( dev-qt/qttest:${_KFSLOT} )"
fi
RESTRICT+=" !test? ( test )"