summaryrefslogtreecommitdiff
path: root/dev-vcs/tig
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/tig')
-rw-r--r--dev-vcs/tig/Manifest4
-rw-r--r--dev-vcs/tig/metadata.xml11
-rw-r--r--dev-vcs/tig/tig-2.3.3.ebuild60
-rw-r--r--dev-vcs/tig/tig-9999.ebuild60
4 files changed, 135 insertions, 0 deletions
diff --git a/dev-vcs/tig/Manifest b/dev-vcs/tig/Manifest
new file mode 100644
index 000000000000..a6e9677f752b
--- /dev/null
+++ b/dev-vcs/tig/Manifest
@@ -0,0 +1,4 @@
+DIST tig-2.3.3.tar.gz 1082818 BLAKE2B 0e9bcd02726b004c233a5efd7f58e4fda478dc1d2b738a7f8c086a3d71807d319ac8bd296b0f7c7569ed69a5b2b1db18e5c957cc5ce890a67b8f6ee7ead29551 SHA512 1d1cdf7184eeb3fea301c1959023f4aa97c4f8e25fc96cd61933ca39cf7549b6c7e1d9517f7ffd45d212ae9542ea4be07370b41c623cf6d0db8d025634b1d6d1
+EBUILD tig-2.3.3.ebuild 1319 BLAKE2B c910552b030958a43c583f0d745c972b6817fe9ef0840409e283f8ec7c3d28b88dfccbf33cf66c4cfeca3247b046c9d70835c01986281af934ed4ed00c53696e SHA512 22997fc3b229a3ca78eee445d4a6761b6bfdb9a379f62d091c57afb17928441f0dc0b2829d48acf3ce474b0785037ad093a4cef5c07813d8fb7169311c6518d1
+EBUILD tig-9999.ebuild 1322 BLAKE2B 6f0cd425ccbe143e45fa5934b2340560a1cad00863cd4691cfb062b745d3f2a8f67672e2e112943d096df23297e11c457d6223e05036780a70cac977591d9302 SHA512 22c37d4453001599b3c7e2cd57da25cb29ac00f44538a916ce1b5cc1c0c95b0e8847a0d5c5223f5fe797355c2c64343eb33dabd34fe84d25ae74a7b26117bafb
+MISC metadata.xml 330 BLAKE2B b73d4c5a79937e78cff86c138950085a6c69ed2b28c8615d37065c7143df047237c014e8c3306b795a3b4fb64a4584fe06bf23d41caa75138f5d6ca07eb75b22 SHA512 bc921303a62d48f0b1b9792df22bf54c1555545c17a2c44a4f946b800c012067cc122011f7735b0f44d0275279450d6290970f127132dc6947ebe09fcba83e98
diff --git a/dev-vcs/tig/metadata.xml b/dev-vcs/tig/metadata.xml
new file mode 100644
index 000000000000..beb9c6e702ff
--- /dev/null
+++ b/dev-vcs/tig/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jonas/tig</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/tig/tig-2.3.3.ebuild b/dev-vcs/tig/tig-2.3.3.ebuild
new file mode 100644
index 000000000000..139284ad8542
--- /dev/null
+++ b/dev-vcs/tig/tig-2.3.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jonas/tig.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+fi
+
+DESCRIPTION="text mode interface for git"
+HOMEPAGE="https://jonas.github.io/tig/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test unicode"
+REQUIRED_USE="test? ( unicode )"
+
+DEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/readline:0="
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+[[ ${PV} == "9999" ]] && DEPEND+=" app-text/asciidoc app-text/xmlto"
+
+# encoding/env issues
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+ [[ ${PV} == "9999" ]] && emake V=1 doc-man doc-html
+}
+
+src_test() {
+ # workaround parallel test failures
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc doc/manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+
+ docinto examples
+ dodoc contrib/*.tigrc
+}
diff --git a/dev-vcs/tig/tig-9999.ebuild b/dev-vcs/tig/tig-9999.ebuild
new file mode 100644
index 000000000000..59b31c7161c2
--- /dev/null
+++ b/dev-vcs/tig/tig-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jonas/tig.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+fi
+
+DESCRIPTION="text mode interface for git"
+HOMEPAGE="https://jonas.github.io/tig/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test unicode"
+REQUIRED_USE="test? ( unicode )"
+
+DEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/readline:0="
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+[[ ${PV} == "9999" ]] && DEPEND+=" app-text/asciidoc app-text/xmlto"
+
+# encoding/env issues
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+ [[ ${PV} == "9999" ]] && emake V=1 doc-man doc-html
+}
+
+src_test() {
+ # workaround parallel test failures
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc doc/manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+
+ docinto examples
+ dodoc contrib/*.tigrc
+}