summaryrefslogtreecommitdiff
path: root/dev-vcs/stgit/stgit-2.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/stgit/stgit-2.3.0.ebuild')
-rw-r--r--dev-vcs/stgit/stgit-2.3.0.ebuild227
1 files changed, 227 insertions, 0 deletions
diff --git a/dev-vcs/stgit/stgit-2.3.0.ebuild b/dev-vcs/stgit/stgit-2.3.0.ebuild
new file mode 100644
index 000000000000..a6c594b071e5
--- /dev/null
+++ b/dev-vcs/stgit/stgit-2.3.0.ebuild
@@ -0,0 +1,227 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.5.4
+
+EAPI=8
+
+CRATES="
+ adler-1.0.2
+ ahash-0.8.3
+ anstream-0.3.2
+ anstyle-1.0.0
+ anstyle-parse-0.2.0
+ anstyle-query-1.0.0
+ anstyle-wincon-1.0.1
+ anyhow-1.0.71
+ arc-swap-1.6.0
+ autocfg-1.1.0
+ bitflags-1.3.2
+ bitflags-2.3.1
+ bstr-1.5.0
+ btoi-0.4.3
+ bzip2-rs-0.1.2
+ cc-1.0.79
+ cfg-if-1.0.0
+ clap-4.3.0
+ clap_builder-4.3.0
+ clap_lex-0.5.0
+ clru-0.6.1
+ colorchoice-1.0.0
+ crc32fast-1.3.2
+ ctrlc-3.3.1
+ curl-0.4.44
+ curl-sys-0.4.62+curl-8.1.0
+ dunce-1.0.4
+ encoding_rs-0.8.32
+ errno-0.3.1
+ errno-dragonfly-0.1.2
+ fastrand-1.9.0
+ filetime-0.2.21
+ flate2-1.0.26
+ form_urlencoded-1.1.0
+ getrandom-0.2.9
+ gix-0.44.1
+ gix-actor-0.20.0
+ gix-attributes-0.12.0
+ gix-bitmap-0.2.3
+ gix-chunk-0.4.1
+ gix-command-0.2.4
+ gix-config-0.22.0
+ gix-config-value-0.12.0
+ gix-credentials-0.14.0
+ gix-date-0.5.0
+ gix-diff-0.29.0
+ gix-discover-0.18.1
+ gix-features-0.29.0
+ gix-fs-0.1.1
+ gix-glob-0.7.0
+ gix-hash-0.11.1
+ gix-hashtable-0.2.0
+ gix-ignore-0.2.0
+ gix-index-0.16.1
+ gix-lock-5.0.1
+ gix-mailmap-0.12.0
+ gix-object-0.29.2
+ gix-odb-0.45.0
+ gix-pack-0.35.0
+ gix-path-0.8.0
+ gix-prompt-0.5.0
+ gix-quote-0.4.3
+ gix-ref-0.29.1
+ gix-refspec-0.10.1
+ gix-revision-0.13.0
+ gix-sec-0.8.0
+ gix-tempfile-5.0.3
+ gix-traverse-0.25.0
+ gix-url-0.18.0
+ gix-utils-0.1.1
+ gix-validate-0.7.4
+ gix-worktree-0.17.1
+ hashbrown-0.12.3
+ hashbrown-0.13.2
+ hermit-abi-0.3.1
+ hex-0.4.3
+ home-0.5.5
+ idna-0.3.0
+ imara-diff-0.1.5
+ indexmap-1.9.3
+ instant-0.1.12
+ io-close-0.3.7
+ io-lifetimes-1.0.11
+ is-terminal-0.4.7
+ itoa-1.0.6
+ kstring-2.0.0
+ libc-0.2.144
+ libz-sys-1.1.9
+ linux-raw-sys-0.3.8
+ lock_api-0.4.9
+ log-0.4.17
+ memchr-2.5.0
+ memmap2-0.5.10
+ minimal-lexical-0.2.1
+ miniz_oxide-0.7.1
+ nix-0.26.2
+ nom-7.1.3
+ num-traits-0.2.15
+ num_threads-0.1.6
+ once_cell-1.17.1
+ openssl-probe-0.1.5
+ openssl-sys-0.9.87
+ parking_lot-0.12.1
+ parking_lot_core-0.9.7
+ percent-encoding-2.2.0
+ pkg-config-0.3.27
+ proc-macro2-1.0.58
+ prodash-23.1.2
+ quote-1.0.27
+ redox_syscall-0.2.16
+ redox_syscall-0.3.5
+ regex-automata-0.1.10
+ rustix-0.37.19
+ ryu-1.0.13
+ same-file-1.0.6
+ schannel-0.1.21
+ scopeguard-1.1.0
+ serde-1.0.163
+ serde_derive-1.0.163
+ serde_json-1.0.96
+ sha1_smol-1.0.0
+ signal-hook-0.3.15
+ signal-hook-registry-1.4.1
+ smallvec-1.10.0
+ socket2-0.4.9
+ static_assertions-1.1.0
+ strsim-0.10.0
+ syn-2.0.16
+ tar-0.4.38
+ tempfile-3.5.0
+ termcolor-1.2.0
+ terminal_size-0.2.6
+ thiserror-1.0.40
+ thiserror-impl-1.0.40
+ time-0.3.21
+ time-core-0.1.1
+ time-macros-0.2.9
+ tinyvec-1.6.0
+ tinyvec_macros-0.1.1
+ unicode-bidi-0.3.13
+ unicode-bom-2.0.2
+ unicode-ident-1.0.9
+ unicode-normalization-0.1.22
+ url-2.3.1
+ utf8parse-0.2.1
+ vcpkg-0.2.15
+ version_check-0.9.4
+ walkdir-2.3.3
+ wasi-0.11.0+wasi-snapshot-preview1
+ winapi-0.3.9
+ winapi-i686-pc-windows-gnu-0.4.0
+ winapi-util-0.1.5
+ winapi-x86_64-pc-windows-gnu-0.4.0
+ windows-0.48.0
+ windows-sys-0.42.0
+ windows-sys-0.45.0
+ windows-sys-0.48.0
+ windows-targets-0.42.2
+ windows-targets-0.48.0
+ windows_aarch64_gnullvm-0.42.2
+ windows_aarch64_gnullvm-0.48.0
+ windows_aarch64_msvc-0.42.2
+ windows_aarch64_msvc-0.48.0
+ windows_i686_gnu-0.42.2
+ windows_i686_gnu-0.48.0
+ windows_i686_msvc-0.42.2
+ windows_i686_msvc-0.48.0
+ windows_x86_64_gnu-0.42.2
+ windows_x86_64_gnu-0.48.0
+ windows_x86_64_gnullvm-0.42.2
+ windows_x86_64_gnullvm-0.48.0
+ windows_x86_64_msvc-0.42.2
+ windows_x86_64_msvc-0.48.0
+ xattr-0.2.3
+"
+
+inherit cargo flag-o-matic
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="https://stacked-git.github.io"
+SRC_URI="$(cargo_crate_uris)"
+SRC_URI+=" https://github.com/stacked-git/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RESTRICT="mirror"
+# License set may be more restrictive as OR is not respected
+# use cargo-license for a more accurate license picture
+LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD Boost-1.0 CC0-1.0 GPL-2 MIT MIT-0 Unicode-DFS-2016 Unlicense ZLIB"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-text/asciidoc )"
+RDEPEND=""
+
+# rust does not use *FLAGS from make.conf, silence portage warning
+# update with proper path to binaries this crate installs, omit leading /
+QA_FLAGS_IGNORED="usr/bin/stg"
+
+src_configure() {
+ filter-lto #bug 897692
+}
+
+src_compile() {
+ cargo_src_compile
+ emake completion
+ emake contrib
+ use doc && emake doc
+}
+
+src_install() {
+ cargo_src_install
+ emake DESTDIR="${D}" prefix="/usr" install-completion
+ emake DESTDIR="${D}" prefix="/usr" install-contrib
+ if use doc; then
+ emake DESTDIR="${D}" prefix="/usr" install-man
+ emake DESTDIR="${D}" prefix="/usr" \
+ htmldir="/usr/share/doc/${PF}" \
+ install-html
+ fi
+}