summaryrefslogtreecommitdiff
path: root/dev-vcs/rcs/rcs-5.10.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/rcs/rcs-5.10.1.ebuild')
-rw-r--r--dev-vcs/rcs/rcs-5.10.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-vcs/rcs/rcs-5.10.1.ebuild b/dev-vcs/rcs/rcs-5.10.1.ebuild
index ac5f14633fd8..d004ccb4c1a6 100644
--- a/dev-vcs/rcs/rcs-5.10.1.ebuild
+++ b/dev-vcs/rcs/rcs-5.10.1.ebuild
@@ -32,6 +32,14 @@ src_configure() {
econf
}
+src_test() {
+ # Tests attempt to call rcs commands on /dev/null and /tmp.
+ # https://bugs.gentoo.org/840173
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict /
+ default
+}
+
src_install() {
emake DESTDIR="${D}" install