summaryrefslogtreecommitdiff
path: root/dev-vcs/rcs/rcs-5.10.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/rcs/rcs-5.10.1.ebuild')
-rw-r--r--dev-vcs/rcs/rcs-5.10.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-vcs/rcs/rcs-5.10.1.ebuild b/dev-vcs/rcs/rcs-5.10.1.ebuild
new file mode 100644
index 000000000000..ca3111c83974
--- /dev/null
+++ b/dev-vcs/rcs/rcs-5.10.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic unpacker
+
+DESCRIPTION="Revision Control System"
+HOMEPAGE="https://www.gnu.org/software/rcs/"
+SRC_URI="mirror://gnu/rcs/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
+IUSE="doc"
+
+RDEPEND="sys-apps/diffutils
+ sys-apps/ed"
+DEPEND="${RDEPEND}"
+BDEPEND="$(unpacker_src_uri_depends)"
+
+src_prepare() {
+ default
+
+ sed -i -e '/gets is a security hole/d' \
+ lib/stdio.in.h || die
+}
+
+src_configure() {
+ append-flags -std=gnu99
+
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog NEWS README
+
+ if use doc; then
+ emake -C doc html
+ rm -R "${ED}"/usr/share/doc/rcs || die
+ mv doc/rcs.html doc/html || die
+ dodoc -r doc/html/
+ fi
+}